summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-15 19:18:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-15 19:18:42 +0000
commit4a9c25b258fe38136c2c3ca37f8edbdeb19522fb (patch)
tree171518a0c9584bbe733a9a607afa747fc98e3631 /dev-util/pida
parentDelete older ebuild. (diff)
downloadgentoo-2-4a9c25b258fe38136c2c3ca37f8edbdeb19522fb.tar.gz
gentoo-2-4a9c25b258fe38136c2c3ca37f8edbdeb19522fb.tar.bz2
gentoo-2-4a9c25b258fe38136c2c3ca37f8edbdeb19522fb.zip
Version bump.
(Portage version: 2.2_rc83_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/ChangeLog8
-rw-r--r--dev-util/pida/pida-0.6.2.ebuild47
2 files changed, 52 insertions, 3 deletions
diff --git a/dev-util/pida/ChangeLog b/dev-util/pida/ChangeLog
index 5207420c438b..a2a663bfeffd 100644
--- a/dev-util/pida/ChangeLog
+++ b/dev-util/pida/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for dev-util/pida
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.24 2010/09/15 19:17:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.25 2010/09/15 19:18:42 arfrever Exp $
+
+*pida-0.6.2 (15 Sep 2010)
15 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
- -pida-0.6.1.ebuild:
- Delete.
+ -pida-0.6.1.ebuild, +pida-0.6.2.ebuild:
+ Version bump.
*pida-0.6.1 (23 Jun 2010)
diff --git a/dev-util/pida/pida-0.6.2.ebuild b/dev-util/pida/pida-0.6.2.ebuild
new file mode 100644
index 000000000000..527725909301
--- /dev/null
+++ b/dev-util/pida/pida-0.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.6.2.ebuild,v 1.1 2010/09/15 19:18:42 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+# json module required.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
+HOMEPAGE="http://pida.co.uk/ http://pypi.python.org/pypi/pida"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="gnome"
+
+RDEPEND="|| ( dev-lang/python:2.7 dev-python/argparse )
+ >=app-editors/gvim-6.3
+ >=dev-python/anyvc-0.3.2
+ >=dev-python/bpython-0.9.7
+ >=dev-python/py-1.3
+ >=dev-python/pygtk-2.8
+ >dev-python/pygtkhelpers-0.4.1
+ gnome? ( >=x11-libs/vte-0.11.11-r2[python] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-util/pkgconfig"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't require argparse with Python 2.7.
+ sed -e "/argparse/d" -i setup.py || die "sed failed"
+
+ epatch "${FILESDIR}/${PN}-0.6.1-fix_implicit_declaration.patch"
+ emake -C contrib/moo moo-pygtk.c
+}
+
+src_install() {
+ distutils_src_install
+ make_desktop_entry pida Pida pida/resources/pixmaps/pida-icon.png Development
+}