summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-07-05 17:46:11 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-07-05 17:46:11 +0000
commit5bf502fd8ca168d67d0aae3c277703442a03aead (patch)
treeb22c096c843e37c82fd69235d375f39ecd6d740b /dev-util/pida
parentStable on sparc wrt #184255 (diff)
downloadgentoo-2-5bf502fd8ca168d67d0aae3c277703442a03aead.tar.gz
gentoo-2-5bf502fd8ca168d67d0aae3c277703442a03aead.tar.bz2
gentoo-2-5bf502fd8ca168d67d0aae3c277703442a03aead.zip
Version bump, removed old version.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/ChangeLog8
-rw-r--r--dev-util/pida/files/digest-pida-0.4.43
-rw-r--r--dev-util/pida/files/digest-pida-0.5.03
-rw-r--r--dev-util/pida/pida-0.5.0.ebuild (renamed from dev-util/pida/pida-0.4.4.ebuild)17
4 files changed, 16 insertions, 15 deletions
diff --git a/dev-util/pida/ChangeLog b/dev-util/pida/ChangeLog
index 01261a2212d1..28d8d40195f4 100644
--- a/dev-util/pida/ChangeLog
+++ b/dev-util/pida/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pida
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.8 2007/05/16 04:47:37 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.9 2007/07/05 17:46:11 pythonhead Exp $
+
+*pida-0.5.0 (05 Jul 2007)
+
+ 05 Jul 2007; Rob Cakebread <pythonhead@gentoo.org> -pida-0.4.4.ebuild,
+ +pida-0.5.0.ebuild:
+ Version bump, removed old version.
*pida-0.4.4 (16 May 2007)
diff --git a/dev-util/pida/files/digest-pida-0.4.4 b/dev-util/pida/files/digest-pida-0.4.4
deleted file mode 100644
index 366c7859959f..000000000000
--- a/dev-util/pida/files/digest-pida-0.4.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 462542ce70b47d16a019b403b741a411 pida-0.4.4.tar.gz 415944
-RMD160 a5ead7e934862ed3b5cc8944d0bf8e01f124697f pida-0.4.4.tar.gz 415944
-SHA256 2a8eb504c4e72a58e961951e449bbb0f200553c97e34233af216f4368cc5656a pida-0.4.4.tar.gz 415944
diff --git a/dev-util/pida/files/digest-pida-0.5.0 b/dev-util/pida/files/digest-pida-0.5.0
new file mode 100644
index 000000000000..9573a2848009
--- /dev/null
+++ b/dev-util/pida/files/digest-pida-0.5.0
@@ -0,0 +1,3 @@
+MD5 5f177b634eddc42133e59dbe21b16341 PIDA-0.5.0.tar.gz 1535859
+RMD160 cc3c115b16b3fe2975987cd4689f7e2a12af89b2 PIDA-0.5.0.tar.gz 1535859
+SHA256 d4e832b69ae919710811521cec523b00722d95caea2c3635fff0c2c641ecb007 PIDA-0.5.0.tar.gz 1535859
diff --git a/dev-util/pida/pida-0.4.4.ebuild b/dev-util/pida/pida-0.5.0.ebuild
index d5b6ea4ce9ec..019f86794b5f 100644
--- a/dev-util/pida/pida-0.4.4.ebuild
+++ b/dev-util/pida/pida-0.5.0.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.4.4.ebuild,v 1.1 2007/05/16 04:47:37 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.5.0.ebuild,v 1.1 2007/07/05 17:46:11 pythonhead Exp $
NEED_PYTHON=2.4
inherit distutils
+MY_P="PIDA-${PV}"
DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
HOMEPAGE="http://pida.co.uk/"
-SRC_URI="http://pida.googlecode.com/files/${P}.tar.gz"
+SRC_URI="http://pida.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gvim gnome"
+IUSE="gnome"
DEPEND=">=dev-python/pygtk-2.8
>=dev-python/setuptools-0.6_rc3
- gvim? ( >=app-editors/gvim-6.3 )
+ >=app-editors/gvim-6.3
gnome? ( >=dev-python/gnome-python-extras-2.14.0-r1 )
>=x11-libs/vte-0.11.11-r2
>=dev-python/kiwi-1.9.1"
RDEPEND="${DEPEND}"
+S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd ${S}
- #Squelch import warnings for un-installed extras
- sed -e "s/self.log.warn/self.log.info/" \
- -i ./pida/core/services.py || die "sed failed"
-}
pkg_setup() {
if ! built_with_use x11-libs/vte python ; then