summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-29 11:57:05 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-29 11:57:05 +0000
commit6c08e8d5b5a8eb31f3b498e9e94f4e6e050923f7 (patch)
treeeed888d336b74158b8fe2041e8c1c59717ef670a /dev-util/squashmerge
parentDrop x32 support in stable ebuild due to broken dependency tree. (diff)
downloadgentoo-2-6c08e8d5b5a8eb31f3b498e9e94f4e6e050923f7.tar.gz
gentoo-2-6c08e8d5b5a8eb31f3b498e9e94f4e6e050923f7.tar.bz2
gentoo-2-6c08e8d5b5a8eb31f3b498e9e94f4e6e050923f7.zip
Bump to the release.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util/squashmerge')
-rw-r--r--dev-util/squashmerge/ChangeLog7
-rw-r--r--dev-util/squashmerge/squashmerge-0.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-util/squashmerge/ChangeLog b/dev-util/squashmerge/ChangeLog
index 0164ffa36f19..a7c9a7b00b55 100644
--- a/dev-util/squashmerge/ChangeLog
+++ b/dev-util/squashmerge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/squashmerge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/squashmerge/ChangeLog,v 1.4 2014/03/24 17:48:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashmerge/ChangeLog,v 1.5 2014/03/29 11:57:05 mgorny Exp $
+
+*squashmerge-0.1 (29 Mar 2014)
+
+ 29 Mar 2014; Michał Górny <mgorny@gentoo.org> +squashmerge-0.1.ebuild:
+ Bump to the release.
24 Mar 2014; Michał Górny <mgorny@gentoo.org> squashmerge-9999.ebuild:
Install file format doc.
diff --git a/dev-util/squashmerge/squashmerge-0.1.ebuild b/dev-util/squashmerge/squashmerge-0.1.ebuild
new file mode 100644
index 000000000000..d17eb1a9fa9c
--- /dev/null
+++ b/dev-util/squashmerge/squashmerge-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashmerge/squashmerge-0.1.ebuild,v 1.1 2014/03/29 11:57:05 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="dev-util/squashdelta delta merge tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashmerge/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+DOCS=( FORMAT )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}