summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-18 11:55:49 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-18 11:55:49 +0000
commit1f4994675a69964bf0542de9858d5d4d20bd8234 (patch)
tree605c240482be2ea7f305ba1f88b98a0caeb1309a /dev-util/strace
parentold (diff)
downloadgentoo-2-1f4994675a69964bf0542de9858d5d4d20bd8234.tar.gz
gentoo-2-1f4994675a69964bf0542de9858d5d4d20bd8234.tar.bz2
gentoo-2-1f4994675a69964bf0542de9858d5d4d20bd8234.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/files/digest-strace-4.5.141
-rw-r--r--dev-util/strace/strace-4.5.14.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index e55024402886..6cde971711df 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.70 2006/01/07 01:10:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.71 2006/01/18 11:55:49 vapier Exp $
+
+*strace-4.5.14 (18 Jan 2006)
+
+ 18 Jan 2006; Mike Frysinger <vapier@gentoo.org> +strace-4.5.14.ebuild:
+ Version bump.
07 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+files/strace-fix-arm-bad-syscall.patch, strace-4.5.12.ebuild:
diff --git a/dev-util/strace/files/digest-strace-4.5.14 b/dev-util/strace/files/digest-strace-4.5.14
new file mode 100644
index 000000000000..4ab0ac74a696
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.5.14
@@ -0,0 +1 @@
+MD5 09bcd5d00ece28f8154dec11cadfce3c strace-4.5.14.tar.bz2 445134
diff --git a/dev-util/strace/strace-4.5.14.ebuild b/dev-util/strace/strace-4.5.14.ebuild
new file mode 100644
index 000000000000..52acd492e913
--- /dev/null
+++ b/dev-util/strace/strace-4.5.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.14.ebuild,v 1.1 2006/01/18 11:55:49 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static aio"
+
+DEPEND="aio? ( dev-libs/libaio )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [[ ${CHOST} == *-freebsd* ]] && epatch "${FILESDIR}"/${PN}-4.5.12-fbsd.patch
+
+ # Fix SuperH support
+ epatch "${FILESDIR}"/strace-dont-use-REG_SYSCALL-for-sh.patch
+ epatch "${FILESDIR}"/${PN}-4.5.12-superh-update.patch
+
+ # Fix building on older ARM machines
+ epatch "${FILESDIR}"/strace-undef-syscall.patch
+ epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
+
+ # Fix libaio support #103427
+ epatch "${FILESDIR}"/${PN}-4.5.12-libaio.patch
+
+ # Remove some obsolete ia64-related hacks from the strace source
+ # (08 Feb 2005 agriffis)
+ epatch "${FILESDIR}"/strace-4.5.8-ia64.patch
+
+ aclocal && autoheader && autoconf && automake || die "autotools failed"
+}
+
+src_compile() {
+ # This is ugly but linux26-headers-2.6.8.1-r2 (and other versions) has some
+ # issues with definition of s64 and friends. This seems to solve
+ # compilation in this case (08 Feb 2005 agriffis)
+ use ia64 && append-flags -D_ASM_IA64_PAL_H
+
+ # Compile fails with -O3 on sparc but works on x86
+ use sparc && replace-flags -O3 -O2
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+
+ econf $(use_enable aio libaio) || die
+ emake || die
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace strace-graph || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}