summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-05 02:05:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-05 02:05:22 +0000
commit287672b79f34f9aab75eefe3e2ea2e031b9ec73e (patch)
tree8f4e51b00cc365eb98891db63672df11784de105 /dev-util/strace
parentAdd dependency on x11-proto/glproto when dri is enabled. (Diego Pettenò, bug (diff)
downloadgentoo-2-287672b79f34f9aab75eefe3e2ea2e031b9ec73e.tar.gz
gentoo-2-287672b79f34f9aab75eefe3e2ea2e031b9ec73e.tar.bz2
gentoo-2-287672b79f34f9aab75eefe3e2ea2e031b9ec73e.zip
Fix building with newer glibcs #149945 by Alexander Jenisch.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog6
-rw-r--r--dev-util/strace/files/strace-4.5.14-PT_GETSIGINFO.patch18
-rw-r--r--dev-util/strace/strace-4.5.14.ebuild15
3 files changed, 30 insertions, 9 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 4d8e45a3e977..cf970e388906 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.90 2006/07/12 20:06:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.91 2006/10/05 02:05:21 vapier Exp $
+
+ 05 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/strace-4.5.14-PT_GETSIGINFO.patch, strace-4.5.14.ebuild:
+ Fix building with newer glibcs #149945 by Alexander Jenisch.
12 Jul 2006; Aron Griffis <agriffis@gentoo.org> strace-4.5.14.ebuild:
Mark 4.5.14 stable on ia64. #137914
diff --git a/dev-util/strace/files/strace-4.5.14-PT_GETSIGINFO.patch b/dev-util/strace/files/strace-4.5.14-PT_GETSIGINFO.patch
new file mode 100644
index 000000000000..194b9d1ff540
--- /dev/null
+++ b/dev-util/strace/files/strace-4.5.14-PT_GETSIGINFO.patch
@@ -0,0 +1,18 @@
+strace assumes that if PT_GETSIGINFO is defined, you're building for ia64 as
+this was the only architecture that exported PT_GETSIGINFO via glibc userspace
+headers. with newer glibc's, support for PT_GETSIGINFO has been added to all
+linux architectures so we can no longer assume PT_GETSIGINFO == ia64.
+
+http://bugs.gentoo.org/149945
+
+--- strace.c
++++ strace.c
+@@ -2251,7 +2251,7 @@
+ if (!cflag
+ && (qual_flags[WSTOPSIG(status)] & QUAL_SIGNAL)) {
+ unsigned long addr = 0, pc = 0;
+-#ifdef PT_GETSIGINFO
++#ifdef PT_CR_IPSR
+ # define PSR_RI 41
+ struct siginfo si;
+ unsigned long psr;
diff --git a/dev-util/strace/strace-4.5.14.ebuild b/dev-util/strace/strace-4.5.14.ebuild
index 942629a29fb0..81e51cbbd73c 100644
--- a/dev-util/strace/strace-4.5.14.ebuild
+++ b/dev-util/strace/strace-4.5.14.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.14.ebuild,v 1.11 2006/07/12 20:06:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.14.ebuild,v 1.12 2006/10/05 02:05:21 vapier Exp $
-inherit flag-o-matic
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit flag-o-matic autotools
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
HOMEPAGE="http://sourceforge.net/projects/strace/"
@@ -21,6 +23,8 @@ src_unpack() {
[[ ${CHOST} == *-freebsd* ]] && epatch "${FILESDIR}"/${PN}-4.5.12-fbsd.patch
+ epatch "${FILESDIR}"/${P}-PT_GETSIGINFO.patch #149945
+
# Fix SuperH support
epatch "${FILESDIR}"/strace-dont-use-REG_SYSCALL-for-sh.patch
epatch "${FILESDIR}"/${PN}-4.5.12-superh-update.patch
@@ -36,15 +40,10 @@ src_unpack() {
# (08 Feb 2005 agriffis)
epatch "${FILESDIR}"/strace-4.5.8-ia64.patch
- aclocal && autoheader && autoconf && automake || die "autotools failed"
+ eautoreconf
}
src_compile() {
- # This is ugly but linux26-headers-2.6.8.1-r2 (and other versions) has some
- # issues with definition of s64 and friends. This seems to solve
- # compilation in this case (08 Feb 2005 agriffis)
- use ia64 && append-flags -D_ASM_IA64_PAL_H
-
# Compile fails with -O3 on sparc but works on x86
use sparc && replace-flags -O3 -O2
filter-lfs-flags