summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-09-20 20:49:50 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-09-20 20:49:50 +0000
commit65f4e7ea49863717cf7d6f1de02420e093bd9325 (patch)
tree578dbe4dcf3722c7952af6e9a15d86a7782d2108 /dev-util/valgrind
parentUpdated Manifest wrt bug #435518. Removed keyworded versions. (diff)
downloadgentoo-2-65f4e7ea49863717cf7d6f1de02420e093bd9325.tar.gz
gentoo-2-65f4e7ea49863717cf7d6f1de02420e093bd9325.tar.bz2
gentoo-2-65f4e7ea49863717cf7d6f1de02420e093bd9325.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog7
-rw-r--r--dev-util/valgrind/valgrind-3.8.1.ebuild100
2 files changed, 106 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index a5d89c29972a..9e9c0bd10af7 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.158 2012/09/18 15:55:03 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.159 2012/09/20 20:49:50 blueness Exp $
+
+*valgrind-3.8.1 (20 Sep 2012)
+
+ 20 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +valgrind-3.8.1.ebuild:
+ Version bump
18 Sep 2012; Johannes Huber <johu@gentoo.org> valgrind-3.7.0-r4.ebuild:
Stable for x86, wrt bug #434884
diff --git a/dev-util/valgrind/valgrind-3.8.1.ebuild b/dev-util/valgrind/valgrind-3.8.1.ebuild
new file mode 100644
index 000000000000..02d62b0da1ab
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.8.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.8.1.ebuild,v 1.1 2012/09/20 20:49:50 blueness Exp $
+
+EAPI="4"
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x64-macos"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ # Respect CFLAGS, LDFLAGS
+ epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+
+ # Changing Makefile.all.am to disable SSP
+ epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.8.0-non-exec-stack.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ filter-flags -m64 -mx32
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x86-macos && myconf="${myconf} --enable-only32bit"
+ use x64-macos && myconf="${myconf} --enable-only64bit"
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Valgrind will not work if glibc does not have debug symbols."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf"
+ ewarn "and remerge glibc. See:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}