summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-07-25 15:34:34 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-07-25 15:34:34 +0000
commit951dc47b7fb3f44bb50e1287383792c5e053c8e9 (patch)
tree547479ada179bf5d8b07ae415829aa9d608435b3 /dev-util/valgrind
parentFix fetch failure, cannot do a SRC_URI arrow from mirror://gentoo. Remove old... (diff)
downloadgentoo-2-951dc47b7fb3f44bb50e1287383792c5e053c8e9.tar.gz
gentoo-2-951dc47b7fb3f44bb50e1287383792c5e053c8e9.tar.bz2
gentoo-2-951dc47b7fb3f44bb50e1287383792c5e053c8e9.zip
Allow valgrind 3.6.1-to build against glibc-2.15 so Andrew doesn't yell at me, bug #390323 comment #31
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog9
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch17
-rw-r--r--dev-util/valgrind/valgrind-3.6.1-r4.ebuild111
3 files changed, 136 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index fe0dc52d44db..4fad140d311c 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.148 2012/07/25 12:34:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.149 2012/07/25 15:34:34 blueness Exp $
+
+*valgrind-3.6.1-r4 (25 Jul 2012)
+
+ 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.1-r4.ebuild, +files/valgrind-3.6.1-glibc-2.15.patch:
+ Allow valgrind 3.6.1-to build against glibc-2.15 so Andrew doesn't yell at
+ me, bug #390323 comment #31
25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
-valgrind-3.4.1-r1.ebuild, -valgrind-3.5.0-r1.ebuild, -valgrind-3.6.0.ebuild,
diff --git a/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch b/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch
new file mode 100644
index 000000000000..e5fc184b53d6
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch
@@ -0,0 +1,17 @@
+diff -Naur valgrind-3.6.1.orig//configure.in valgrind-3.6.1/configure.in
+--- valgrind-3.6.1.orig//configure.in 2012-07-25 14:46:59.600964127 +0000
++++ valgrind-3.6.1/configure.in 2012-07-25 14:48:56.910013096 +0000
+@@ -763,6 +763,13 @@
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
++ 2.15)
++ AC_MSG_RESULT(2.15 family)
++ AC_DEFINE([GLIBC_2_15], 1, [Define to 1 if you're using glibc 2.15.x])
++ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
++ ;;
+ aix5)
+ AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
+ AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
diff --git a/dev-util/valgrind/valgrind-3.6.1-r4.ebuild b/dev-util/valgrind/valgrind-3.6.1-r4.ebuild
new file mode 100644
index 000000000000..8d6fd9974cf7
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.1-r4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.1-r4.ebuild,v 1.1 2012/07/25 15:34:34 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi qt4"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.6.0-non-exec-stack.patch
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}"/${PN}-3.4.1-glibc-2.10.1.patch
+
+ # Remove automagic dependency on qt4
+ epatch "${FILESDIR}"/${PN}-3.6.1-user-enable-qt4.patch
+
+ # Allow valgrind to build against linux-3, bug #370857
+ epatch "${FILESDIR}"/${PN}-3.6.1-linux-3.patch
+
+ # Allow valgrind to build against glibc-2.14, bug #378157
+ epatch "${FILESDIR}"/${PN}-3.6.1-glibc-2.14.patch
+
+ # Allow valgrind to build against glibc-2.15, bug #390323 comment 31
+ epatch "${FILESDIR}"/${PN}-3.6.1-glibc-2.15.patch
+
+ # Back port of fix for bug #403179, https://bugs.kde.org/show_bug.cgi?id=277045
+ epatch "${FILESDIR}"/${PN}-3.6.1-fix-unhandled-opcode.patch
+
+ # Fix stricter use of dir variables, bugs #397429 and #403779
+ epatch "${FILESDIR}"/${PN}-3.6.1-automake-1.11.3.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ if ! use qt4; then
+ myconf="${myconf} --disable-qtcore"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ ewarn "Valgrind will not work if glibc does not have debug symbols."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf"
+ ewarn "and remerge glibc. See:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}