summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-17 17:08:17 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-17 17:08:17 +0000
commit0f0ef02c446e902bc78b934b656b33c27fbaf527 (patch)
treea8ebfb2cf8c4d5c0edaa46af2151734eb79de142 /dev-util
parentAdded ROUTE patch to get iptables 1.2.9 to compile properly - Bug #32778 (diff)
downloadgentoo-2-0f0ef02c446e902bc78b934b656b33c27fbaf527.tar.gz
gentoo-2-0f0ef02c446e902bc78b934b656b33c27fbaf527.tar.bz2
gentoo-2-0f0ef02c446e902bc78b934b656b33c27fbaf527.zip
Fixes #33680.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog8
-rw-r--r--dev-util/eclipse-sdk/Manifest3
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-2.1.2.ebuild221
-rw-r--r--dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.21
4 files changed, 232 insertions, 1 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 2a49b0eb6207..23b9e2535dbb 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.4 2003/11/03 18:16:26 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.5 2003/11/17 17:08:17 karltk Exp $
+*eclipse-sdk-2.1.2 (17 Nov 2003)
+
+ 17 Nov 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-2.1.2.ebuild:
+ New upstream version. Fixes #33680.
+
*eclipse-sdk-2.1.1 (04 Nov 2003)
04 Oct 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
diff --git a/dev-util/eclipse-sdk/Manifest b/dev-util/eclipse-sdk/Manifest
index 56b40c413cf6..1d2d30a0de01 100644
--- a/dev-util/eclipse-sdk/Manifest
+++ b/dev-util/eclipse-sdk/Manifest
@@ -1,8 +1,11 @@
MD5 33b6a16db3c7c859125089c5cb9417aa ChangeLog 1156
MD5 1d0493e018ee744da0fd103bd767909a eclipse-sdk-2.1.ebuild 82879
MD5 f7c1fff0ba8c4f8670d6d242f5026a7f eclipse-sdk-2.1.1.ebuild 7417
+MD5 40278ec7a8e15c3f11a988f45287c7a5 eclipse-sdk-2.1.2.ebuild 7416
MD5 9cc8d5162e981d7b7fc1ef9fa1ac0e65 metadata.xml 919
+MD5 dcdc95ad11ff30777b3ce56b43746737 eclipse-sdk-2.1.2.ebuild~ 7413
MD5 5bea1174eca3d2e368ad728e5086b24a files/digest-eclipse-sdk-2.1 86
MD5 a01c2dd64e43d4ee9dd96dbf0b4578c7 files/eclipse.desktop 213
MD5 9b30c0b9d4af6ed66a09e216efadefe6 files/eclipse 1067
MD5 76c2f3ddbb548ca9d3f1522498f51bc0 files/digest-eclipse-sdk-2.1.1 88
+MD5 cc086062a18b18e0a241f27d0ed2de44 files/digest-eclipse-sdk-2.1.2 88
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-2.1.2.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-2.1.2.ebuild
new file mode 100644
index 000000000000..3a5e446538e9
--- /dev/null
+++ b/dev-util/eclipse-sdk/eclipse-sdk-2.1.2.ebuild
@@ -0,0 +1,221 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download2.eclipse.org/downloads/drops/R-2.1.2-200311030802/eclipse-sourceBuild-srcIncluded-2.1.2.zip"
+IUSE="gtk motif gnome kde"
+
+SLOT="0"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.5.3
+ >=sys-apps/findutils-4.1.7
+ >=app-shells/tcsh-6.11"
+
+# removed since the bin lives in /opt and this in /usr
+# !dev-util/eclipse-platform-bin
+# !dev-util/eclipse-jdt-bin
+# !dev-util/eclipse-cdt-bin"
+
+RDEPEND=">=virtual/jdk-1.3
+ kde? ( kde-base/kde virtual/motif ) :
+ ( gnome? ( =gnome-base/gnome-vfs-2* ) :
+ ( motif? ( virtual/motif ) :
+ ( >=x11-libs/gtk+-2.2.1-r1 ) ) )
+ motif? ( virtual/motif )
+ gnome? ( =gnome-base/gnome-vfs-2* )
+ gtk? ( >=x11-libs/gtk+-2.2.1-r1 )"
+
+S=${WORKDIR}/eclipse
+
+src_compile() {
+
+ # This ebuild is doing some slightly funky things since the
+ # source tarball also contains all the binaries for eclipse. On
+ # top of this, there are a ton of files that need to be merged
+ # so instead of specifying all these files, we're instead
+ # removing all the extra fluff from the source tree and then
+ # merging it all over when we're done.
+
+ # This ebuild will compile eclipse for gtk2, motif, and kde
+ # toolkits depending on the use flags set. If all are set, the
+ # default version linked to is the GTK2 version. When building
+ # for KDE though, the motif version must be built with support
+ # for KDE. Apparently the motif build also supports KDE when
+ # this is done - I could be wrong though.
+
+ gtk_launcher_src_dir="${WORKDIR}/plugins/platform-launcher/library/gtk"
+ motif_launch_src_dir="${WORKDIR}/plugins/platform-launcher/library/motif"
+ gtk_swt_src_dir=${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library
+ motif_swt_src_dir=${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT\ PI/motif/library
+
+ case $ARCH in
+ sparc)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/solaris/sparc"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/solaris/sparc"
+ ;;
+ x86)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/linux/x86"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/linux/x86"
+ ;;
+ ppc)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/linux/ppc"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/linux/ppc"
+ ;;
+ esac
+
+ use gtk && gtk=y
+ use motif && motif=y
+ use gnome && gnome=y gtk=y
+ use kde && kde=y motif=y
+
+ # force gtk to be the default if motif isn't selected
+ if ! [ ${motif} = "y" ] ; then
+ gtk=y
+ fi
+
+ cd ${WORKDIR}
+
+ # First build all java code
+
+ # this export is pulled from the build shellscript supplied by
+ # eclipse. It fixes an outOfMemory exception during the ant build
+ # process.
+ export ANT_OPTS=-Xmx256m
+
+ override_motif_target=
+ if [ "${gtk}" = "y" ] ; then
+ einfo "Building GTK+ frontend"
+ ant -buildfile build.xml -Dos=linux -Dws=gtk
+ #only do a compile/install for motif... Don't do a buildDoc. This will save time...
+ override_motif_target=compile install
+ fi
+ if [ "${motif}" = "y" ] ; then
+ einfo "Building Motif frontend"
+ ant -buildfile ${override_motif_target} build.xml -Dos=linux -Dws=motif
+ fi
+
+ # remove all .so files shipped with the tarball
+ find ${WORKDIR} -name '*.so' -exec rm -f {} \;
+
+ # remove the eclipse binary copied from the ant build above.
+ rm -f ${WORKDIR}/eclipse
+
+
+ # I'm replacing these pkg-config lines since --libs for them
+ # returns -pthread instead of -lpthread and remove the -Wl, since
+ # ld doesn't know what to do with it.
+
+ GNOME_LIB=`pkg-config --libs gnome-vfs-2.0 | sed -e "s:-pthread:-lpthread:" -e "s:-Wl,--export:--export:"`
+ GTHREAD_LIB=`pkg-config --libs gthread-2.0 | sed -e "s:-pthread:-lpthread:"`
+
+ # Build for the gtk toolkit
+ if [ "${gtk}" = "y" ] ; then
+ # Build the eclipse gtk binary
+ cd ${WORKDIR}/plugins/platform-launcher/library/gtk
+ tcsh build.csh -arch $ARCH || die
+ mv eclipse ${WORKDIR}/eclipse-gtk
+
+ cd "${gtk_swt_src_dir}"
+ cp ${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+
+ cp make_gtk.mak make_gtk.mak.orig
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:$JAVA_HOME:" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:${GTHREAD_LIB}:" \
+ -e "s:\`pkg-config --libs gnome-vfs-2.0\`:${GNOME_LIB}:" \
+ -e "s:-I\$(JAVA_JNI):-I\$(JAVA_JNI) -I\$(JAVA_JNI)/linux:" \
+ make_gtk.mak.orig > make_gtk.mak
+
+ make -f make_gtk.mak make_swt
+ if [ "${gnome}" = "y" ] ; then
+ make -f make_gtk.mak make_gnome
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir "${gtk_swt_dest_dir}"
+ mv *.so "${gtk_swt_dest_dir}"
+ make -f make_linux.mak clean #do a clean since everything is going to end up getting merged
+ fi
+
+ # Build for the motif toolkit
+ if [ "${motif}" = "y" ] ; then
+ # Build the eclipse motif binary
+ cd ${WORKDIR}/plugins/platform-launcher/library/motif
+ tcsh build.csh -arch $ARCH || die
+ mv eclipse ${WORKDIR}/eclipse-motif
+
+ cd "${motif_swt_src_dir}"
+ cp ${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+
+ mv make_linux.mak make_linux.mak.orig
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:$JAVA_HOME:" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:/bluebird/teamswt/swt-builddir/motif21:/usr/X11R6:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:${GTHREAD_LIB}:" \
+ -e "s:\`pkg-config --libs gnome-vfs-2.0\`:${GNOME_LIB}:" \
+ -e "s:/usr/lib/qt3:/usr/qt/3:" \
+ -e "s:-lkdecore:-L\`kde-config --prefix\`/lib -lkdecore:" \
+ -e "s:-I/usr/include/kde:-I\`kde-config --prefix\`/include:" \
+ -e "s:-I\$(JAVA_JNI):-I\$(JAVA_JNI) -I\$(JAVA_JNI)/linux:" \
+ make_linux.mak.orig > make_linux.mak
+
+ make -f make_linux.mak make_swt
+ if [ "${gnome}" = "y" ] ; then
+ make -f make_linux.mak make_gnome
+ fi
+ if [ "${kde}" = "y" ] ; then
+ make -f make_linux.mak make_kde
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir "${motif_swt_dest_dir}"
+ mv *.so "${motif_swt_dest_dir}"
+ make -f make_linux.mak clean #do a clean since everything is going to end up getting merged
+ fi
+
+
+ # remove all the java files so we can install this.
+ # there is no install target in build.xml for some reason and
+ # we don't want all of these files merged.
+ # also remove all the .project, .classpath and build.* files spread out all over the place
+ find ${WORKDIR} -name '*.java' -exec rm -f {} \;
+ find ${WORKDIR} -name '.classpath' -exec rm -f {} \;
+ find ${WORKDIR} -name '.project' -exec rm -f {} \;
+ find ${WORKDIR} -name 'build.*' -exec rm -f {} \;
+
+}
+
+src_install() {
+ cd ${WORKDIR}
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/eclipse
+
+ dodir /usr/lib/eclipse
+ exeinto /usr/lib/eclipse
+
+ if [ -f eclipse-gtk ] ; then
+ doexe eclipse-gtk
+ dosym /usr/lib/eclipse/eclipse-gtk /usr/lib/eclipse/eclipse
+ fi
+ if [ -f eclipse-motif ] ; then
+ doexe eclipse-motif
+ dosym /usr/bin/eclipse /usr/bin/eclipse-motif
+ if ! [ -f eclipse-gtk ] ; then
+ dosym /usr/lib/eclipse/eclipse-motif /usr/lib/eclipse/eclipse
+ fi
+ fi
+
+ insinto /usr/lib/eclipse
+ doins plugins/org.eclipse.platform/.eclipseproduct
+
+ cp -dpR features icon.xpm plugins splash.bmp startup.jar \
+ ${D}/usr/lib/eclipse/
+
+ insinto /usr/share/gnome/apps/Development
+ doins ${FILESDIR}/eclipse.desktop
+}
diff --git a/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.2 b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.2
new file mode 100644
index 000000000000..7fcf57ff9d33
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.2
@@ -0,0 +1 @@
+MD5 24fc3bf3be3d3f3e306786ab7b13bcce eclipse-sourceBuild-srcIncluded-2.1.2.zip 45014406