summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-03-08 19:42:19 +0000
committerMarius Mauch <genone@gentoo.org>2004-03-08 19:42:19 +0000
commit364e45710d7a19cf49d6bdd300b7d2c4d3835f70 (patch)
tree65415b21d60d31690625a5c879827ddd9bc8183d /dev-util
parentpppoatm.so fix (diff)
downloadgentoo-2-364e45710d7a19cf49d6bdd300b7d2c4d3835f70.tar.gz
gentoo-2-364e45710d7a19cf49d6bdd300b7d2c4d3835f70.tar.bz2
gentoo-2-364e45710d7a19cf49d6bdd300b7d2c4d3835f70.zip
crappy package requires info files :(
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gambas/ChangeLog9
-rw-r--r--dev-util/gambas/files/Makefile.am-0.9015
-rw-r--r--dev-util/gambas/files/digest-gambas-0.90-r11
-rw-r--r--dev-util/gambas/gambas-0.90-r1.ebuild75
4 files changed, 92 insertions, 8 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index f12fc6dd7b34..59e1cd0a5036 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.6 2004/02/28 03:03:16 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.7 2004/03/08 19:42:19 genone Exp $
+
+*gambas-0.90-r1 (08 Mar 2004)
+
+ 08 Mar 2004; Marius Mauch <genone@gentoo.org> gambas-0.90-r1.ebuild,
+ files/Makefile.am-0.90:
+ info files are required so don't skip that step but just remove the KDE
+ specific component files.
28 Feb 2004; Marius Mauch <genone@gentoo.org> gambas-0.90.ebuild,
files/Makefile.am-0.90:
diff --git a/dev-util/gambas/files/Makefile.am-0.90 b/dev-util/gambas/files/Makefile.am-0.90
index 2dfd74bd572f..d033284d9466 100644
--- a/dev-util/gambas/files/Makefile.am-0.90
+++ b/dev-util/gambas/files/Makefile.am-0.90
@@ -8,13 +8,14 @@ install-exec-local:
@(cd $(srcdir)/app; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
gbc -ag; gba; rm -rf .gambas; $(INSTALL) $$p $(bindir); done)
- # This part is producing segfaults on kde stuff
- #@echo
- #@echo "Creating the library info files..."
- #@$(INSTALL) -d $(libdir)/info
- #@$(bindir)/gbi -a
- #@rm -f $(libdir)/lib.gb.la
- #@rm -f $(libdir)/lib.gb.so*
+ # This part is producing segfaults on kde stuff, so we remove the KDE stuff
+ @rm -f $(libdir)/lib.gb.qt.kde*.component
+ @echo
+ @echo "Creating the library info files..."
+ @$(INSTALL) -d $(libdir)/info
+ @$(bindir)/gbi -a
+ @rm -f $(libdir)/lib.gb.la
+ @rm -f $(libdir)/lib.gb.so*
@echo
@echo "Installing the gambas help files..."
diff --git a/dev-util/gambas/files/digest-gambas-0.90-r1 b/dev-util/gambas/files/digest-gambas-0.90-r1
new file mode 100644
index 000000000000..4471e2fc406c
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.90-r1
@@ -0,0 +1 @@
+MD5 1f3211e2c97a354205123a71441e6ced gambas-0.90.tar.bz2 2646331
diff --git a/dev-util/gambas/gambas-0.90-r1.ebuild b/dev-util/gambas/gambas-0.90-r1.ebuild
new file mode 100644
index 000000000000..cfdbfac57c4e
--- /dev/null
+++ b/dev-util/gambas/gambas-0.90-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90-r1.ebuild,v 1.1 2004/03/08 19:42:19 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="postgres mysql sdl doc curl debug"
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-base/xfree-4.3.0
+ >=x11-libs/qt-3.2
+ >=kde-base/kdelibs-3.2
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-ftp/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Os::' configure
+ # replace braindead Makefile
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-${PV}" ./Makefile.am
+ automake
+ # patch against hardcoded paths
+ epatch ${FILESDIR}/non-symlink-${PV}.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-kde --enable-qt"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+
+ if use debug; then
+ myconf="${myconf} --disable-optimization --enable-debug"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog COPYING TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/help ${D}/usr/share/examples
+}