summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-05-28 07:09:40 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-05-28 07:09:40 +0000
commit4d3225e4821f32a1fbea8eebf49c1f1a6e566960 (patch)
treea6c77d18d906507ce0905a294a01422693647334 /dev-util
parentRemove old versions (diff)
downloadgentoo-2-4d3225e4821f32a1fbea8eebf49c1f1a6e566960.tar.gz
gentoo-2-4d3225e4821f32a1fbea8eebf49c1f1a6e566960.tar.bz2
gentoo-2-4d3225e4821f32a1fbea8eebf49c1f1a6e566960.zip
Version bump rebar to 2.3.0
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rebar/ChangeLog7
-rw-r--r--dev-util/rebar/rebar-2.3.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-util/rebar/ChangeLog b/dev-util/rebar/ChangeLog
index 51f581123059..185274a4e7e7 100644
--- a/dev-util/rebar/ChangeLog
+++ b/dev-util/rebar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/rebar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.4 2014/03/30 20:49:25 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.5 2014/05/28 07:09:40 djc Exp $
+
+*rebar-2.3.0 (28 May 2014)
+
+ 28 May 2014; Dirkjan Ochtman <djc@gentoo.org> +rebar-2.3.0.ebuild:
+ Version bump rebar to 2.3.0
*rebar-2.2.0 (30 Mar 2014)
diff --git a/dev-util/rebar/rebar-2.3.0.ebuild b/dev-util/rebar/rebar-2.3.0.ebuild
new file mode 100644
index 000000000000..b132de56472d
--- /dev/null
+++ b/dev-util/rebar/rebar-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/rebar-2.3.0.ebuild,v 1.1 2014/05/28 07:09:40 djc Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}