summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-12-09 14:12:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-12-09 14:12:49 +0000
commit4dcb7f23680889523801d7db9069286efda6c170 (patch)
treef11c3b2263b2f7c4e7e4d65541433bce1a6b309c /dev-util
parentVersion bump. (diff)
downloadgentoo-2-4dcb7f23680889523801d7db9069286efda6c170.tar.gz
gentoo-2-4dcb7f23680889523801d7db9069286efda6c170.tar.bz2
gentoo-2-4dcb7f23680889523801d7db9069286efda6c170.zip
QA: Revbump. Fix ruby bindings and perl-5.10 issues. Non-maintainer commit. Fixes bug #117061 and #256686.
(Portage version: 2.2_rc56/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/libconf/ChangeLog10
-rw-r--r--dev-util/libconf/files/0.42.10-perl5.10.patch11
-rw-r--r--dev-util/libconf/libconf-0.42.10-r2.ebuild (renamed from dev-util/libconf/libconf-0.42.10-r1.ebuild)11
3 files changed, 26 insertions, 6 deletions
diff --git a/dev-util/libconf/ChangeLog b/dev-util/libconf/ChangeLog
index 2e07e056ca3f..b61d6c838073 100644
--- a/dev-util/libconf/ChangeLog
+++ b/dev-util/libconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/libconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.48 2009/07/02 23:57:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.49 2009/12/09 14:12:49 scarabeus Exp $
+
+*libconf-0.42.10-r2 (09 Dec 2009)
+
+ 09 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.42.10-perl5.10.patch, -libconf-0.42.10-r1.ebuild,
+ +libconf-0.42.10-r2.ebuild:
+ QA: Revbump. Fix ruby bindings and perl-5.10 issues. Non-maintainer
+ commit. Fixes bug #117061 and #256686.
02 Jul 2009; Jeroen Roovers <jer@gentoo.org> libconf-0.42.10-r1.ebuild:
Marked ~hppa too.
diff --git a/dev-util/libconf/files/0.42.10-perl5.10.patch b/dev-util/libconf/files/0.42.10-perl5.10.patch
new file mode 100644
index 000000000000..df146eb6f453
--- /dev/null
+++ b/dev-util/libconf/files/0.42.10-perl5.10.patch
@@ -0,0 +1,11 @@
+--- perl-Libconf-0.42.10/bindings/c/src/conf2xml.c 2005-11-07 01:02:03.000000000 -0800
++++ perl-Libconf-0.42.10/bindings/c/src/conf2xml.c.new 2008-07-22 17:01:33.000000000 -0700
+@@ -19,7 +19,7 @@
+ char *embedding[] = { "", "-e", "0" };
+
+ if (my_perl != NULL) conf2xml_free();
+- PERL_SYS_INIT3(&argc,&argv,&env);
++ PERL_SYS_INIT3(NULL,NULL,NULL);
+ my_perl = perl_alloc();
+ perl_construct( my_perl );
+ perl_parse(my_perl, xs_init, 3, embedding, (char **)NULL);
diff --git a/dev-util/libconf/libconf-0.42.10-r1.ebuild b/dev-util/libconf/libconf-0.42.10-r2.ebuild
index dee32a26eded..5f38d84b5555 100644
--- a/dev-util/libconf/libconf-0.42.10-r1.ebuild
+++ b/dev-util/libconf/libconf-0.42.10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10-r1.ebuild,v 1.8 2009/07/02 23:57:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10-r2.ebuild,v 1.1 2009/12/09 14:12:49 scarabeus Exp $
inherit eutils multilib toolchain-funcs
@@ -27,7 +27,8 @@ bindings() {
local mybindings
mybindings="bash"
use python && mybindings="${mybindings} python"
- use ruby && mybindings="${mybindings} ruby"
+ # ruby bindings require c bindings - bug #117061
+ use ruby && mybindings="${mybindings} c ruby"
echo ${mybindings}
}
@@ -36,6 +37,7 @@ src_unpack() {
cd "${S}"
[[ ${USERLAND} == *BSD ]] && epatch "${FILESDIR}/${PV}-fbsd.patch"
+ epatch "${FILESDIR}/${PV}-per5.10.patch"
# Multilib fix
sed -i \
@@ -63,7 +65,6 @@ src_install() {
BINDINGS="$(bindings)" \
PREFIX="${D}/usr" DESTDIR="${D}" ROOT="${D}" \
CPA="cp -pR" install || die "emake install failed"
- dodoc AUTHORS ChangeLog \
- bindings/ruby/src/{AUTHORS,README} \
- bindings/python/src/README
+ dodoc AUTHORS ChangeLog || die
+ use python && { newdoc newdoc bindings/ruby/src/AUTHORS AUTHORS.python || die ; }
}