summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-08-21 20:14:33 +0000
committerMichael Januszewski <spock@gentoo.org>2005-08-21 20:14:33 +0000
commit6394249f8d10a179cddc37549ef36a9e15b0fc18 (patch)
treefc169ef797809744329f135b1fc300b44f067510 /dev-util
parentRemove old ebuilds. (diff)
downloadgentoo-2-6394249f8d10a179cddc37549ef36a9e15b0fc18.tar.gz
gentoo-2-6394249f8d10a179cddc37549ef36a9e15b0fc18.tar.bz2
gentoo-2-6394249f8d10a179cddc37549ef36a9e15b0fc18.zip
Version bump (bug #103006).
(Portage version: 1.589-cvs)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog8
-rw-r--r--dev-util/oprofile/files/digest-oprofile-0.9.11
-rw-r--r--dev-util/oprofile/oprofile-0.9.1.ebuild80
3 files changed, 88 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 9c919ba28f4f..993afbf11ae4 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.20 2005/07/28 14:16:51 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.21 2005/08/21 20:14:33 spock Exp $
+
+*oprofile-0.9.1 (21 Aug 2005)
+
+ 21 Aug 2005; Michał Januszewski <spock@gentoo.org>
+ +oprofile-0.9.1.ebuild:
+ Version bump (bug #103006).
28 Jul 2005; Caleb Tennis <caleb@gentoo.org> oprofile-0.8.1.ebuild,
oprofile-0.8.2.ebuild, oprofile-0.9.ebuild:
diff --git a/dev-util/oprofile/files/digest-oprofile-0.9.1 b/dev-util/oprofile/files/digest-oprofile-0.9.1
new file mode 100644
index 000000000000..393abaf89eb2
--- /dev/null
+++ b/dev-util/oprofile/files/digest-oprofile-0.9.1
@@ -0,0 +1 @@
+MD5 c25a05406e30e81a6afbd3264191fa37 oprofile-0.9.1.tar.gz 673244
diff --git a/dev-util/oprofile/oprofile-0.9.1.ebuild b/dev-util/oprofile/oprofile-0.9.1.ebuild
new file mode 100644
index 000000000000..375f111311f9
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1.ebuild,v 1.1 2005/08/21 20:14:33 spock Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( $(qt_min_version 3.3) )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/oprofile-0.8.2.patch
+}
+
+src_compile() {
+ check_KV
+
+ local myconf=""
+
+ if use qt
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}