summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-28 17:55:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-28 17:55:35 +0000
commit651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21 (patch)
tree3d2e1223705783bb60d0a948072a0a4a41625265 /dev-util
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.tar.gz
gentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.tar.bz2
gentoo-2-651a0ec7ccb4f05e7ceae01ce8c4a397d277bc21.zip
Version bump, 1.5.5 series is pretty ready for primetime.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog9
-rw-r--r--dev-util/git/files/20080528-git-1.5.5.3-noperl.patch327
-rw-r--r--dev-util/git/files/vim-ftdetect-gitcommit.vim3
-rw-r--r--dev-util/git/git-1.5.5.3.ebuild282
4 files changed, 620 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 9502f9f88b1c..8305816e8528 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/git
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.269 2008/04/29 22:35:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.270 2008/05/28 17:55:35 robbat2 Exp $
+
+*git-1.5.5.3 (28 May 2008)
+
+ 28 May 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/20080528-git-1.5.5.3-noperl.patch,
+ +files/vim-ftdetect-gitcommit.vim, +git-1.5.5.3.ebuild:
+ Version bump, 1.5.5 series is pretty ready for primetime.
*git-1.5.5.1-r1 (29 Apr 2008)
diff --git a/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch b/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch
new file mode 100644
index 000000000000..5fbdc4136a96
--- /dev/null
+++ b/dev-util/git/files/20080528-git-1.5.5.3-noperl.patch
@@ -0,0 +1,327 @@
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/builtin-add.c git-1.5.5.3/builtin-add.c
+--- git-1.5.5.3.orig/builtin-add.c 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/builtin-add.c 2008-05-28 10:38:12.566970120 -0700
+@@ -135,6 +135,7 @@
+ free(seen);
+ }
+
++#ifndef NO_PERL
+ static const char **validate_pathspec(int argc, const char **argv, const char *prefix)
+ {
+ const char **pathspec = get_pathspec(prefix, argv);
+@@ -170,6 +171,7 @@
+ free(args);
+ return status;
+ }
++#endif
+
+ static struct lock_file lock_file;
+
+@@ -182,8 +184,10 @@
+ OPT__DRY_RUN(&show_only),
+ OPT__VERBOSE(&verbose),
+ OPT_GROUP(""),
++#ifndef NO_PERL
+ OPT_BOOLEAN('i', "interactive", &add_interactive, "interactive picking"),
+ OPT_BOOLEAN('p', "patch", &patch_interactive, "interactive patching"),
++#endif
+ OPT_BOOLEAN('f', NULL, &ignored_too, "allow adding otherwise ignored files"),
+ OPT_BOOLEAN('u', NULL, &take_worktree_changes, "update tracked files"),
+ OPT_BOOLEAN( 0 , "refresh", &refresh_only, "don't add, only refresh the index"),
+@@ -198,10 +202,12 @@
+
+ argc = parse_options(argc, argv, builtin_add_options,
+ builtin_add_usage, 0);
++#ifndef NO_PERL
+ if (patch_interactive)
+ add_interactive = 1;
+ if (add_interactive)
+ exit(interactive_add(argc, argv, prefix));
++#endif
+
+ git_config(git_default_config);
+
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/builtin-commit.c git-1.5.5.3/builtin-commit.c
+--- git-1.5.5.3.orig/builtin-commit.c 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/builtin-commit.c 2008-05-28 10:38:25.556703720 -0700
+@@ -97,7 +97,9 @@
+ OPT_GROUP("Commit contents options"),
+ OPT_BOOLEAN('a', "all", &all, "commit all changed files"),
+ OPT_BOOLEAN('i', "include", &also, "add specified files to index for commit"),
++#ifndef NO_PERL
+ OPT_BOOLEAN(0, "interactive", &interactive, "interactively add files"),
++#endif
+ OPT_BOOLEAN('o', "only", &only, "commit only specified files"),
+ OPT_BOOLEAN('n', "no-verify", &no_verify, "bypass pre-commit hook"),
+ OPT_BOOLEAN(0, "amend", &amend, "amend previous commit"),
+@@ -217,6 +219,7 @@
+ struct path_list partial;
+ const char **pathspec = NULL;
+
++#ifndef NO_PERL
+ if (interactive) {
+ interactive_add(argc, argv, prefix);
+ if (read_cache() < 0)
+@@ -224,6 +227,7 @@
+ commit_style = COMMIT_AS_IS;
+ return get_index_file();
+ }
++#endif
+
+ if (read_cache() < 0)
+ die("index file corrupt");
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/Makefile git-1.5.5.3/Makefile
+--- git-1.5.5.3.orig/Makefile 2008-05-28 10:38:03.608016000 -0700
++++ git-1.5.5.3/Makefile 2008-05-28 10:38:12.571288044 -0700
+@@ -130,6 +130,8 @@
+ #
+ # Define NO_PERL_MAKEMAKER if you cannot use Makefiles generated by perl's
+ # MakeMaker (e.g. using ActiveState under Cygwin).
++
++# Define NO_PERL if you do not want Perl scripts at all.
+ #
+ # Define NO_TCLTK if you do not want Tcl/Tk GUI.
+ #
+@@ -255,6 +257,8 @@
+ SCRIPT_SH += git-submodule.sh
+ SCRIPT_SH += git-web--browse.sh
+
++SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH))
++ifndef NO_PERL
+ SCRIPT_PERL += git-add--interactive.perl
+ SCRIPT_PERL += git-archimport.perl
+ SCRIPT_PERL += git-cvsexportcommit.perl
+@@ -263,10 +267,11 @@
+ SCRIPT_PERL += git-relink.perl
+ SCRIPT_PERL += git-send-email.perl
+ SCRIPT_PERL += git-svn.perl
+-
+-SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH)) \
+- $(patsubst %.perl,%,$(SCRIPT_PERL)) \
+- git-instaweb
++SCRIPTS += $(patsubst %.perl,%,$(SCRIPT_PERL)) \
++ git-instaweb
++else
++SCRIPT_PERL =
++endif
+
+ # Empty...
+ EXTRA_PROGRAMS =
+@@ -315,7 +320,10 @@
+ ALL_PROGRAMS = $(PROGRAMS) $(SCRIPTS)
+
+ # what 'all' will build but not install in gitexecdir
+-OTHER_PROGRAMS = git$X gitweb/gitweb.cgi
++OTHER_PROGRAMS = git$X
++ifndef NO_PERL
++OTHER_PROGRAMS += gitweb/gitweb.cgi
++endif
+
+ # Set paths to tools early so that they can be used for version tests.
+ ifndef SHELL_PATH
+@@ -716,6 +724,10 @@
+ endif
+ endif
+
++ifdef NO_PERL
++ BASIC_CFLAGS += -DNO_PERL
++endif
++
+ ifdef ZLIB_PATH
+ BASIC_CFLAGS += -I$(ZLIB_PATH)/include
+ EXTLIBS += -L$(ZLIB_PATH)/$(lib) $(CC_LD_DYNPATH)$(ZLIB_PATH)/$(lib)
+@@ -896,6 +908,11 @@
+ ifeq ($(TCLTK_PATH),)
+ NO_TCLTK=NoThanks
+ endif
++ifeq ($(PERL_PATH),)
++NO_PERL=NoThanks
++export NO_PERL
++export NO_PERL_MAKEMAKER
++endif
+
+ QUIET_SUBDIR0 = +$(MAKE) -C # space to separate -C and subdir
+ QUIET_SUBDIR1 =
+@@ -968,7 +985,9 @@
+ $(QUIET_SUBDIR0)git-gui $(QUIET_SUBDIR1) all
+ $(QUIET_SUBDIR0)gitk-git $(QUIET_SUBDIR1) all
+ endif
++ifndef NO_PERL
+ $(QUIET_SUBDIR0)perl $(QUIET_SUBDIR1) PERL_PATH='$(PERL_PATH_SQ)' prefix='$(prefix_SQ)' all
++endif
+ $(QUIET_SUBDIR0)templates $(QUIET_SUBDIR1)
+
+ strip: $(PROGRAMS) git$X
+@@ -1007,6 +1026,7 @@
+ chmod +x $@+ && \
+ mv $@+ $@
+
++ifndef NO_PERL
+ $(patsubst %.perl,%,$(SCRIPT_PERL)): perl/perl.mak
+
+ perl/perl.mak: GIT-CFLAGS perl/Makefile perl/Makefile.PL
+@@ -1065,6 +1085,7 @@
+ $@.sh > $@+ && \
+ chmod +x $@+ && \
+ mv $@+ $@
++endif # NO_PERL
+
+ configure: configure.ac
+ $(QUIET_GEN)$(RM) $@ $<+ && \
+@@ -1218,7 +1239,9 @@
+ $(INSTALL) $(ALL_PROGRAMS) '$(DESTDIR_SQ)$(gitexecdir_SQ)'
+ $(INSTALL) git$X '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C templates DESTDIR='$(DESTDIR_SQ)' install
++ifndef NO_PERL
+ $(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
++endif
+ ifndef NO_TCLTK
+ $(MAKE) -C gitk-git install
+ $(MAKE) -C git-gui install
+@@ -1307,9 +1330,11 @@
+ $(RM) -r $(GIT_TARNAME) .doc-tmp-dir
+ $(RM) $(GIT_TARNAME).tar.gz git-core_$(GIT_VERSION)-*.tar.gz
+ $(RM) $(htmldocs).tar.gz $(manpages).tar.gz
+- $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C Documentation/ clean
++ifndef NO_PERL
++ $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C perl clean
++endif
+ $(MAKE) -C templates/ clean
+ $(MAKE) -C t/ clean
+ ifndef NO_TCLTK
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/lib-git-svn.sh git-1.5.5.3/t/lib-git-svn.sh
+--- git-1.5.5.3.orig/t/lib-git-svn.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/lib-git-svn.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -6,6 +6,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-svn tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ GIT_DIR=$PWD/.git
+ GIT_SVN_DIR=$GIT_DIR/svn/git-svn
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t5505-remote.sh git-1.5.5.3/t/t5505-remote.sh
+--- git-1.5.5.3.orig/t/t5505-remote.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t5505-remote.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -3,6 +3,12 @@
+ test_description='git remote porcelain-ish'
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ setup_repository () {
+ mkdir "$1" && (
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t7501-commit.sh git-1.5.5.3/t/t7501-commit.sh
+--- git-1.5.5.3.orig/t/t7501-commit.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t7501-commit.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -38,7 +38,7 @@
+ "echo King of the bongo >file &&
+ ! git-commit -m foo -a file"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "using paths with --interactive" \
+ "echo bong-o-bong >file &&
+ ! echo 7 | git-commit -m foo --interactive file"
+@@ -119,7 +119,7 @@
+ "echo 'gak' >file && \
+ git-commit -m 'author' --author 'Rubber Duck <rduck@convoy.org>' -a"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "interactive add" \
+ "echo 7 | git-commit --interactive | grep 'What now'"
+
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9001-send-email.sh git-1.5.5.3/t/t9001-send-email.sh
+--- git-1.5.5.3.orig/t/t9001-send-email.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9001-send-email.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -2,6 +2,12 @@
+
+ test_description='git-send-email'
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-send-email tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ PROG='git send-email'
+ test_expect_success \
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9200-git-cvsexportcommit.sh git-1.5.5.3/t/t9200-git-cvsexportcommit.sh
+--- git-1.5.5.3.orig/t/t9200-git-cvsexportcommit.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9200-git-cvsexportcommit.sh 2008-05-28 10:38:12.571288044 -0700
+@@ -13,6 +13,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsexportcommit tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ CVSROOT=$(pwd)/cvsroot
+ CVSWORK=$(pwd)/cvswork
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9400-git-cvsserver-server.sh git-1.5.5.3/t/t9400-git-cvsserver-server.sh
+--- git-1.5.5.3.orig/t/t9400-git-cvsserver-server.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9400-git-cvsserver-server.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -17,6 +17,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsserver tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+ perl -e 'use DBI; use DBD::SQLite' >/dev/null 2>&1 || {
+ test_expect_success 'skipping git-cvsserver tests, Perl SQLite interface unavailable' :
+ test_done
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9500-gitweb-standalone-no-errors.sh git-1.5.5.3/t/t9500-gitweb-standalone-no-errors.sh
+--- git-1.5.5.3.orig/t/t9500-gitweb-standalone-no-errors.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9500-gitweb-standalone-no-errors.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -67,6 +67,13 @@
+ }
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping gitweb-standalone-no-errors tests, NO_PERL defined' :
++ test_done
++ exit
++fi
++
+
+ perl -MEncode -e 'decode_utf8("", Encode::FB_CROAK)' >/dev/null 2>&1 || {
+ test_expect_success 'skipping gitweb tests, perl version is too old' :
+diff -Nuar --exclude '*.orig' --exclude '*.rej' git-1.5.5.3.orig/t/t9600-cvsimport.sh git-1.5.5.3/t/t9600-cvsimport.sh
+--- git-1.5.5.3.orig/t/t9600-cvsimport.sh 2008-05-28 00:56:46.000000000 -0700
++++ git-1.5.5.3/t/t9600-cvsimport.sh 2008-05-28 10:38:12.573745493 -0700
+@@ -15,6 +15,12 @@
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ cvsps_version=`cvsps -h 2>&1 | sed -ne 's/cvsps version //p'`
+ case "$cvsps_version" in
diff --git a/dev-util/git/files/vim-ftdetect-gitcommit.vim b/dev-util/git/files/vim-ftdetect-gitcommit.vim
new file mode 100644
index 000000000000..5f2a20eaaca8
--- /dev/null
+++ b/dev-util/git/files/vim-ftdetect-gitcommit.vim
@@ -0,0 +1,3 @@
+" $Header: /var/cvsroot/gentoo-x86/dev-util/git/files/vim-ftdetect-gitcommit.vim,v 1.1 2008/05/28 17:55:35 robbat2 Exp $
+" This is what is suggested by the contrib/vim/README that ships with Git
+autocmd BufNewFile,BufRead COMMIT_EDITMSG set filetype=gitcommit
diff --git a/dev-util/git/git-1.5.5.3.ebuild b/dev-util/git/git-1.5.5.3.ebuild
new file mode 100644
index 000000000000..45a05b49dfe0
--- /dev/null
+++ b/dev-util/git/git-1.5.5.3.ebuild
@@ -0,0 +1,282 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.5.3.ebuild,v 1.1 2008/05/28 17:55:35 robbat2 Exp $
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="curl cgi doc emacs gtk iconv mozsha1 perl ppcsha1 tk threads webdav xinetd cvs subversion vim-syntax"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ app-arch/cpio
+ perl? ( dev-lang/perl )
+ tk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+# dev-perl/{Authen-SASL,Net-SMTP-SSL} are used by git-send-email
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/Error
+ dev-perl/Net-SMTP-SSL
+ dev-perl/Authen-SASL
+ cgi? ( virtual/perl-CGI )
+ cvs? ( >=dev-util/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
+ subversion? ( dev-util/subversion dev-perl/libwww-perl dev-perl/TermReadKey )
+ )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=72${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use perl ; then
+ if use cgi || use cvs || use subversion ; then
+ eerror "You must built dev-util/git with USE=perl and the"
+ eerror "applicable USE flag to use any of the following:"
+ eerror "gitweb, git-cvs*, git-svn, git-archimport, git-quiltimport"
+ die "You need USE=perl to satisfy your other USE= requests!"
+ fi
+ fi
+}
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk || myopts="${myopts} NO_TCLTK=YesPlease"
+ use perl || myopts="${myopts} NO_PERL=YesPlease"
+ use threads && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
+ use subversion || myopts="${myopts} NO_SVN_TESTS=YesPlease"
+
+ export MY_MAKEOPTS="${myopts}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && cd "${S}"/Documentation && unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
+ epatch "${FILESDIR}"/20080528-${PN}-1.5.5.3-noperl.patch
+
+ sed -i \
+ -e "s:^\(CFLAGS =\).*$:\1 ${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS =\).*$:\1 ${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ -e 's:ln :ln -s :g' \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+ if use perl && use cgi ; then
+ emake ${MY_MAKEOPTS} \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ gitweb/gitweb.cgi || die "make gitweb/gitweb.cgi failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
+ die "make install failed"
+
+ doman man?/*
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/{,vc-}git.el* || \
+ die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}"/"${SITELISP}"/${PN}/.nosearch
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/fast-import/git-p4
+ dodoc contrib/fast-import/git-p4.txt
+ newbin contrib/fast-import/import-tars.perl import-tars
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/syntax/gitcommit.vim
+ insinto /usr/share/vim/vimfiles/ftdetect/
+ newins "${FILESDIR}"/vim-ftdetect-gitcommit.vim gitcommit.vim
+ fi
+
+ dodir /usr/share/${PN}/contrib
+ # The following are excluded:
+ # svnimport - use git-svn
+ # p4import - excluded because fast-import has a better one
+ # examples - these are stuff that is not used in Git anymore actually
+ # patches - stuff the Git guys made to go upstream to other places
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh stats \
+ workdir convert-objects blameview ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ if use perl && use cgi ; then
+ dodir /usr/share/${PN}/gitweb
+ insinto /usr/share/${PN}/gitweb
+ doins "${S}"/gitweb/gitweb.cgi
+ doins "${S}"/gitweb/gitweb.css
+ doins "${S}"/gitweb/git-{favicon,logo}.png
+
+ # Make sure it can run
+ fperms 0755 /usr/share/${PN}/gitweb/gitweb.cgi
+
+ # INSTALL discusses configuration issues, not just installation
+ docinto /
+ newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
+ newdoc "${S}"/gitweb/README README.gitweb
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+ fi
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ local disabled=""
+ local tests_cvs="t9200-git-cvsexportcommit.sh \
+ t9400-git-cvsserver-server.sh \
+ t9600-cvsimport.sh"
+ local tests_perl="t5502-quickfetch.sh \
+ t5512-ls-remote.sh \
+ t5520-pull.sh"
+
+ # Unzip is used only for the testcase code, not by any normal parts of Git.
+ has_version app-arch/unzip || \
+ einfo "Disabling tar-tree tests" && \
+ disabled="${disabled} \
+ t5000-tar-tree.sh"
+
+ if ! has userpriv "${FEATURES}"; then
+ ewarn "Skipping CVS tests because CVS does not work as root!"
+ ewarn "You should retest with FEATURES=userpriv!"
+ disabled="${disabled} \
+ ${tests_cvs}"
+ fi
+
+ use cvs && \
+ has_version dev-util/cvs && \
+ built_with_use dev-util/cvs server || \
+ einfo "Disabling CVS tests (needs dev-util/cvs[USE=server])" && \
+ disabled="${disabled} \
+ ${tests_cvs}"
+
+ use perl || \
+ einfo "Disabling tests that need Perl" && \
+ disabled="${disabled} \
+ ${tests_perl}"
+
+ # Reset all previously disabled tests
+ cd "${S}/t"
+ for i in *.sh.DISABLED ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
+ done
+ einfo "Disabled tests:"
+ for i in ${disabled} ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
+ done
+ cd "${S}"
+ # Now run the tests
+ einfo "Start test run"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "GNU Emacs has built-in Git support in versions greater 22.1."
+ elog "You can disable the emacs USE flag for dev-util/git"
+ elog "if you are using such a version."
+ fi
+ if use subversion && ! built_with_use dev-util/subversion perl ; then
+ ewarn "You must build dev-util/subversion with USE=perl"
+ ewarn "to get the full functionality of git-svn!"
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache )"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}