summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-06-17 21:15:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-06-17 21:15:34 +0000
commit931cfee8a6696b6f488434a0f216d2b5222a3882 (patch)
tree3094288ce654bbc386ae29a094d90d325c2f622b /dev-util
parentVersion bump, bug 271482 (diff)
downloadgentoo-2-931cfee8a6696b6f488434a0f216d2b5222a3882.tar.gz
gentoo-2-931cfee8a6696b6f488434a0f216d2b5222a3882.tar.bz2
gentoo-2-931cfee8a6696b6f488434a0f216d2b5222a3882.zip
Version bump. Bug fixes. No need to eautoreconf, closes: #273823.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/glade/ChangeLog7
-rw-r--r--dev-util/glade/glade-3.6.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index 72c1f7c4c5b3..488fa29f136e 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/glade
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.115 2009/06/09 13:22:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.116 2009/06/17 21:15:34 eva Exp $
+
+*glade-3.6.5 (17 Jun 2009)
+
+ 17 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org> +glade-3.6.5.ebuild:
+ Version bump. Bug fixes. No need to eautoreconf, closes: #273823.
09 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
glade-2.12.2-r1.ebuild:
diff --git a/dev-util/glade/glade-3.6.5.ebuild b/dev-util/glade/glade-3.6.5.ebuild
new file mode 100644
index 000000000000..afde6ec33d96
--- /dev/null
+++ b/dev-util/glade/glade-3.6.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.6.5.ebuild,v 1.1 2009/06/17 21:15:34 eva Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+MY_PN="glade3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GNOME GUI Builder"
+HOMEPAGE="http://glade.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc gnome python"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.14.0
+ >=dev-libs/libxml2-2.4
+ gnome? (
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonoboui-2.0 )
+ python? ( >=dev-python/pygtk-2.10.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ sys-devel/gettext
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.9
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ $(use_enable gnome)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}