summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-12 20:40:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-12 20:40:50 +0000
commitb255abd0f4093a546d9ad5c1df7c8d76c51fc78c (patch)
tree904bd48d76016dc1b65951319f8c23e0bf8710b4 /dev-util
parentstable x86, security bug 332449 (diff)
downloadgentoo-2-b255abd0f4093a546d9ad5c1df7c8d76c51fc78c.tar.gz
gentoo-2-b255abd0f4093a546d9ad5c1df7c8d76c51fc78c.tar.bz2
gentoo-2-b255abd0f4093a546d9ad5c1df7c8d76c51fc78c.zip
Respect CXXFLAGS,LDFLAGS. Bug #331803. Keyworded for amd64. Thanks to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel2gas/ChangeLog11
-rw-r--r--dev-util/intel2gas/intel2gas-1.3.3-r3.ebuild40
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/intel2gas/ChangeLog b/dev-util/intel2gas/ChangeLog
index 4bd172711d00..208187040e8c 100644
--- a/dev-util/intel2gas/ChangeLog
+++ b/dev-util/intel2gas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/intel2gas
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/intel2gas/ChangeLog,v 1.9 2009/08/09 15:30:54 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intel2gas/ChangeLog,v 1.10 2010/08/12 20:40:50 hwoarang Exp $
+
+*intel2gas-1.3.3-r3 (12 Aug 2010)
+
+ 12 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +intel2gas-1.3.3-r3.ebuild:
+ Respect CXXFLAGS,LDFLAGS. Bug #331803. Keyworded for amd64. Thanks to
+ Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
09 Aug 2009; Víctor Ostorga <vostorga@gentoo.org>
intel2gas-1.3.3-r2.ebuild, +files/intel2gas-1.3.3-glibc210.patch:
diff --git a/dev-util/intel2gas/intel2gas-1.3.3-r3.ebuild b/dev-util/intel2gas/intel2gas-1.3.3-r3.ebuild
new file mode 100644
index 000000000000..5a867042af08
--- /dev/null
+++ b/dev-util/intel2gas/intel2gas-1.3.3-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intel2gas/intel2gas-1.3.3-r3.ebuild,v 1.1 2010/08/12 20:40:50 hwoarang Exp $
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="Converts assembler source from Intel (NASM), to AT&T (gas)"
+HOMEPAGE="http://www.niksula.cs.hut.fi/~mtiihone/intel2gas/"
+SRC_URI="http://www.niksula.cs.hut.fi/~mtiihone/intel2gas/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-segfault.patch
+ epatch "${FILESDIR}"/${PN}-nostrip.patch
+ epatch "${FILESDIR}"/${P}-cxx.patch
+ epatch "${FILESDIR}"/${P}-constchar.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
+ eautomake
+ sed -i -e "s:\$(CXXFLAGS):& ${LDFLAGS} :" \
+ -e "/^${PN}/{n; s:\$(CXX) :& ${CXXFLAGS} ${LDFLAGS} :}" \
+ "${S}"/Makefile.in
+}
+
+src_compile() {
+ tc-export CXX
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ install || die
+ fperms ugo+r /usr/share/intel2gas/i2g/main.syntax
+ dodoc README DATAFILES BUGS
+}