summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-02-19 12:31:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-02-19 12:31:23 +0000
commitb5748ab658e8e0d28d8fe00cb1f2477ef59254ce (patch)
treed94a8caa6faa6e2ef971f705ecc5f0ef443bbf62 /dev-util
parentAdd patch to fix build with libnotify 0.7, by Samuli Suominen, bug #353848 (diff)
downloadgentoo-2-b5748ab658e8e0d28d8fe00cb1f2477ef59254ce.tar.gz
gentoo-2-b5748ab658e8e0d28d8fe00cb1f2477ef59254ce.tar.bz2
gentoo-2-b5748ab658e8e0d28d8fe00cb1f2477ef59254ce.zip
Version bump, added patch to fix qtcore automagic
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.1-user-enable-qt4.patch89
-rw-r--r--dev-util/valgrind/valgrind-3.6.1.ebuild97
3 files changed, 193 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 423ec28b61e2..f3063f952c88 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.119 2011/01/27 04:51:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.120 2011/02/19 12:31:23 blueness Exp $
+
+*valgrind-3.6.1 (19 Feb 2011)
+
+ 19 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.1.ebuild, +files/valgrind-3.6.1-user-enable-qt4.patch:
+ Version bump, added patch to fix qtcore automagic
27 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> valgrind-3.6.0.ebuild,
+files/valgrind-3.6.0-glibc-2.13.patch,
diff --git a/dev-util/valgrind/files/valgrind-3.6.1-user-enable-qt4.patch b/dev-util/valgrind/files/valgrind-3.6.1-user-enable-qt4.patch
new file mode 100644
index 000000000000..8f7c39465d43
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.1-user-enable-qt4.patch
@@ -0,0 +1,89 @@
+--- configure.in.orig 2011-02-17 14:29:14.000000000 -0500
++++ configure.in 2011-02-17 15:05:46.000000000 -0500
+@@ -1692,7 +1692,8 @@
+ # NEEDED BY THE REGRESSION TEST PROGRAMS.
+
+
+-# The test below verifies whether the QtCore package been installed.
++# The test below first checks if the user has manaually disabled
++# QtCore. It then verifies whether the QtCore package been installed.
+ # This test works as follows:
+ # - If pkg-config was not installed at the time autogen.sh was run,
+ # the definition of the PKG_CHECK_EXISTS() macro will not be found by
+@@ -1709,37 +1710,49 @@
+ # the pkg-config executable is not present on the system on which the
+ # configure script is run.
+
+-ifdef(
+- [PKG_CHECK_EXISTS],
+- [PKG_CHECK_EXISTS(
+- [QtCore],
++AC_ARG_ENABLE(qtcore,
++ AS_HELP_STRING(--enable-qtcore, compile with qtcore support),
+ [
+- PKG_CHECK_MODULES([QTCORE], [QtCore])
+- # Paranoia: don't trust the result reported by pkg-config, but when
+- # pkg-config reports that QtCore has been found, verify whether linking
+- # programs with QtCore succeeds.
+- AC_LANG(C++)
+- safe_CXXFLAGS="${CXXFLAGS}"
+- CXXFLAGS="${QTCORE_CFLAGS} ${QTCORE_LIBS} $mflag_primary"
+- AC_TRY_LINK(
+- [#include <QMutex>],
+- [QMutex Mutex;],
+- [ac_have_qtcore=yes],
+- [
+- AC_MSG_WARN([Although pkg-config detected Qt4, linking Qt4 programs fails. Skipping Qt4.])
+- ac_have_qtcore=no
+- ]
+- )
+- CXXFLAGS="${safe_CXXFLAGS}"
++ if test x$enableval = xno ; then
++ AC_MSG_CHECKING([for QTCORE ])
++ AC_MSG_RESULT([QTCORE is manually distabled.])
++ [ac_have_qtcore=no]
++ fi
+ ],
+ [
+- ac_have_qtcore=no
++ ifdef(
++ [PKG_CHECK_EXISTS],
++ [PKG_CHECK_EXISTS(
++ [QtCore],
++ [
++ PKG_CHECK_MODULES([QTCORE], [QtCore])
++ # Paranoia: don't trust the result reported by pkg-config, but when
++ # pkg-config reports that QtCore has been found, verify whether linking
++ # programs with QtCore succeeds.
++ AC_LANG(C++)
++ safe_CXXFLAGS="${CXXFLAGS}"
++ CXXFLAGS="${QTCORE_CFLAGS} ${QTCORE_LIBS} $mflag_primary"
++ AC_TRY_LINK(
++ [#include <QMutex>],
++ [QMutex Mutex;],
++ [ac_have_qtcore=yes],
++ [
++ AC_MSG_WARN([Although pkg-config detected Qt4, linking Qt4 programs fails. Skipping Qt4.])
++ ac_have_qtcore=no
++ ]
++ )
++ CXXFLAGS="${safe_CXXFLAGS}"
++ ],
++ [
++ ac_have_qtcore=no
++ ]
++ )
++ ],
++ AC_MSG_WARN([pkg-config has not been installed or is too old.])
++ AC_MSG_WARN([Detection of Qt4 will be skipped.])
++ [ac_have_qtcore=no]
++ )
+ ]
+- )
+- ],
+- AC_MSG_WARN([pkg-config has not been installed or is too old.])
+- AC_MSG_WARN([Detection of Qt4 will be skipped.])
+- [ac_have_qtcore=no]
+ )
+
+ AM_CONDITIONAL([HAVE_QTCORE], [test x$ac_have_qtcore = xyes])
diff --git a/dev-util/valgrind/valgrind-3.6.1.ebuild b/dev-util/valgrind/valgrind-3.6.1.ebuild
new file mode 100644
index 000000000000..b777b2c55b8d
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.1.ebuild,v 1.1 2011/02/19 12:31:23 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi qt4"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.6.0-non-exec-stack.patch
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}"/${PN}-3.4.1-glibc-2.10.1.patch
+
+ # Remove automagic dependency on qt4
+ epatch "${FILESDIR}"/${PN}-3.6.1-user-enable-qt4.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ if ! use qt4; then
+ myconf="${myconf} --disable-qtcore"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ if use ppc || use ppc64 || use amd64 ; then
+ ewarn "Valgrind will not work on ppc, ppc64 or amd64 if glibc does not have"
+ ewarn "debug symbols (see https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=274771)."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf and"
+ ewarn "remerge glibc."
+ fi
+}