summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-07-12 12:21:10 +0000
committerOlivier Crête <tester@gentoo.org>2008-07-12 12:21:10 +0000
commitd45e5ef472ee5ee3696db18e8b4fa06546ee00d2 (patch)
treef1f3a145cad11eac150f8155f7b85d20b9e2dec5 /dev-util
parentVersion bump for bug fixes (diff)
downloadgentoo-2-d45e5ef472ee5ee3696db18e8b4fa06546ee00d2.tar.gz
gentoo-2-d45e5ef472ee5ee3696db18e8b4fa06546ee00d2.tar.bz2
gentoo-2-d45e5ef472ee5ee3696db18e8b4fa06546ee00d2.zip
Version bump, bug #226027
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/insight/ChangeLog7
-rw-r--r--dev-util/insight/insight-6.8.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-util/insight/ChangeLog b/dev-util/insight/ChangeLog
index 238dabdf684e..0a4e68b830f5 100644
--- a/dev-util/insight/ChangeLog
+++ b/dev-util/insight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/insight
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/ChangeLog,v 1.46 2008/05/01 22:30:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/ChangeLog,v 1.47 2008/07/12 12:21:10 tester Exp $
+
+*insight-6.8 (12 Jul 2008)
+
+ 12 Jul 2008; Olivier Crête <tester@gentoo.org> +insight-6.8.ebuild:
+ Version bump, bug #226027
01 May 2008; Mike Frysinger <vapier@gentoo.org> insight-6.7.1-r1.ebuild:
Mark amd64 stable #217467.
diff --git a/dev-util/insight/insight-6.8.ebuild b/dev-util/insight/insight-6.8.ebuild
new file mode 100644
index 000000000000..c1b6f686b932
--- /dev/null
+++ b/dev-util/insight/insight-6.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.8.ebuild,v 1.1 2008/07/12 12:21:10 tester Exp $
+
+inherit eutils flag-o-matic
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="A graphical interface to the GNU debugger"
+HOMEPAGE="http://sourceware.org/insight/"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="sys-libs/ncurses
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-6.6-DESTDIR.patch
+ epatch "${FILESDIR}"/${PN}-6.6-burn-paths.patch
+
+ cd "${S}/tk"
+ epatch "${FILESDIR}"/tkImgGIF.patch
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing # tcl code sucks
+ strip-linguas -u bfd/po opcodes/po
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ --enable-gdbtk \
+ --disable-tui \
+ --datadir=/usr/share/${PN} \
+ || die
+ emake || die
+}
+
+src_install() {
+ # the tcl-related subdirs are not parallel safe
+ emake -j1 DESTDIR="${D}" install || die
+
+ # Don't install docs when building a cross-insight
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ dodoc gdb/gdbtk/{README,TODO}
+ fi
+
+ # the gui tcl code does not consider any of the configure
+ # options given it ... instead, it requires the path to
+ # be /usr/share/redhat/...
+ mv "${D}"/usr/share/${PN}/redhat "${D}"/usr/share/ || die
+
+ # scrub all the cruft we dont want
+ local x
+ cd "${D}"/usr/bin
+ for x in * ; do
+ [[ ${x} != *insight ]] && rm -f ${x}
+ done
+ cd "${D}"
+ rm -rf usr/{include,man,share/{info,locale,man}}
+ rm -rf usr/lib*
+}