summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-06-19 00:31:55 +0000
committerJonathan Callen <abcd@gentoo.org>2010-06-19 00:31:55 +0000
commit4f59b860c9f5605f817f16b9aad204107f9cee03 (patch)
tree7c7c63e95b6fa0b9762c3195bf8635759d7ea1ca /dev-vcs/cvsps/cvsps-2.1-r1.ebuild
parentMove package from dev-util/cvsgraph to dev-vcs/cvsgraph (diff)
downloadgentoo-2-4f59b860c9f5605f817f16b9aad204107f9cee03.tar.gz
gentoo-2-4f59b860c9f5605f817f16b9aad204107f9cee03.tar.bz2
gentoo-2-4f59b860c9f5605f817f16b9aad204107f9cee03.zip
Move package from dev-util/cvsps to dev-vcs/cvsps
(Portage version: 2.2_rc67/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/cvsps/cvsps-2.1-r1.ebuild')
-rw-r--r--dev-vcs/cvsps/cvsps-2.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/cvsps/cvsps-2.1-r1.ebuild b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
new file mode 100644
index 000000000000..8363b3ba8751
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1-r1.ebuild,v 1.1 2010/06/19 00:31:55 abcd Exp $
+
+inherit eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.cobite.com/cvsps/"
+SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-solaris.patch
+ # no configure around
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
+ fi
+}
+
+src_install() {
+ dobin cvsps || die
+ doman cvsps.1
+ dodoc README CHANGELOG
+}