summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-01 22:41:40 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-01 22:41:40 +0000
commit45d2a0de48787a5d23de55398700254d015a5abb (patch)
tree0f5a9a347761100a197b68cf15d1b1d7490bb73b /dev-vcs
parentVersion bump to latest. Rpune older. (diff)
downloadgentoo-2-45d2a0de48787a5d23de55398700254d015a5abb.tar.gz
gentoo-2-45d2a0de48787a5d23de55398700254d015a5abb.tar.bz2
gentoo-2-45d2a0de48787a5d23de55398700254d015a5abb.zip
Initial ebuild for patchwork client.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pwclient/ChangeLog9
-rw-r--r--dev-vcs/pwclient/metadata.xml7
-rw-r--r--dev-vcs/pwclient/pwclient-20121105131501.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/pwclient/ChangeLog b/dev-vcs/pwclient/ChangeLog
new file mode 100644
index 000000000000..f4f0c7920bc5
--- /dev/null
+++ b/dev-vcs/pwclient/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-vcs/pwclient
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/pwclient/ChangeLog,v 1.1 2012/12/01 22:41:40 vapier Exp $
+
+*pwclient-20121105131501 (01 Dec 2012)
+
+ 01 Dec 2012; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +pwclient-20121105131501.ebuild:
+ Initial ebuild for patchwork client.
diff --git a/dev-vcs/pwclient/metadata.xml b/dev-vcs/pwclient/metadata.xml
new file mode 100644
index 000000000000..7123fa8f9ece
--- /dev/null
+++ b/dev-vcs/pwclient/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/pwclient/pwclient-20121105131501.ebuild b/dev-vcs/pwclient/pwclient-20121105131501.ebuild
new file mode 100644
index 000000000000..12615012cc38
--- /dev/null
+++ b/dev-vcs/pwclient/pwclient-20121105131501.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/pwclient/pwclient-20121105131501.ebuild,v 1.1 2012/12/01 22:41:40 vapier Exp $
+
+EAPI="4"
+
+# The PV comes from:
+# git clone ${EGIT_REPO_URI}
+# cd patchwork
+# EGIT_COMMIT=$(git log -n1 --format=%H apps/patchwork/bin/pwclient)
+# date --date="$(git log -n1 --format=%ci ${EGIT_COMMIT})" -u +%Y%m%d%H%M%S
+EGIT_REPO_URI="git://ozlabs.org/home/jk/git/patchwork"
+EGIT_COMMIT="bc695f5a7e0a2dd184dc0eae7a923be24b1b1723"
+
+DESCRIPTION="command line utility for interacting with patchwork repos"
+HOMEPAGE="http://jk.ozlabs.org/projects/patchwork/"
+SRC_URI="http://repo.or.cz/w/patchwork.git/blob_plain/${EGIT_COMMIT}:/apps/patchwork/bin/pwclient -> ${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python"
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ newbin "${DISTDIR}"/${P} ${PN}
+}