summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2013-12-31 01:56:03 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2013-12-31 01:56:03 +0000
commit7462d3496757050ebee1abb78107042131eef36e (patch)
tree105ba136c43c120a64961c98df6d213bcba62d8b /dev-vcs
parentRevert xorg-server version change (bug #494460). (diff)
downloadgentoo-2-7462d3496757050ebee1abb78107042131eef36e.tar.gz
gentoo-2-7462d3496757050ebee1abb78107042131eef36e.tar.bz2
gentoo-2-7462d3496757050ebee1abb78107042131eef36e.zip
Initial commit.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/github-pages-publish/ChangeLog9
-rw-r--r--dev-vcs/github-pages-publish/Manifest3
-rw-r--r--dev-vcs/github-pages-publish/github-pages-publish-0.1.ebuild35
-rw-r--r--dev-vcs/github-pages-publish/metadata.xml19
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-vcs/github-pages-publish/ChangeLog b/dev-vcs/github-pages-publish/ChangeLog
new file mode 100644
index 000000000000..528dff9e6584
--- /dev/null
+++ b/dev-vcs/github-pages-publish/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-vcs/github-pages-publish
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/github-pages-publish/ChangeLog,v 1.1 2013/12/31 01:56:03 rafaelmartins Exp $
+
+*github-pages-publish-0.1 (31 Dec 2013)
+
+ 31 Dec 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +github-pages-publish-0.1.ebuild, +metadata.xml:
+ Initial commit.
diff --git a/dev-vcs/github-pages-publish/Manifest b/dev-vcs/github-pages-publish/Manifest
new file mode 100644
index 000000000000..76467eb89d1b
--- /dev/null
+++ b/dev-vcs/github-pages-publish/Manifest
@@ -0,0 +1,3 @@
+DIST github-pages-publish-0.1.tar.gz 3233 SHA256 97f381a3b9d08db533b857cb9d39b0fa8bae8bcb8df23a2a96f6adeb8ad71700 SHA512 46489d22f893840196b4ebf9b3a035534073565010aa17eff6ca3387c3113043b89d122876b174278c35891cf512c1254af732d97d2f731916a9280536bef40a WHIRLPOOL f660249341dd4b3cb8f0a00d85e8239ccaa3a6697bb36d1585734812a29345b6294a7839cf4c86dfdfcef2086ac5cabd6cd98318bcf5c36d3b45b6a141bc09b9
+EBUILD github-pages-publish-0.1.ebuild 953 SHA256 e10f8fc03f160d54ddeb8cf9e6560bc66479e49dab241ddf7a37df1b8224e934 SHA512 0f90c38dc46da466ffe6222dfa5b9daf3ae8b9f24a4bdd068bf62ef3585306b4e617a13185c5ae04d81b5ac7ae14cbf3e5ee7a01d1432cbd9bef0f8f8ccb485d WHIRLPOOL e576590bdf5fe0ac24cd986f60f29fe7a48a0e4c2dee1664408ec0ecbf7336407d86024ab64eb72ca740379d17f24b500d2eb9412e78c69a9eba7448d22512cb
+MISC metadata.xml 602 SHA256 b3d1f3efd753f8e060edf6dda22f007ebcf5d16a2698eb814f3ba4ed9209ddb6 SHA512 0b60d771200c3192956a795862aba72d085e3f4ba75ef327dd9daf9ddbdd329812079f1c10da8abcbc14889e63e1732ca49d5d9608e8231731c513bbeeba7e15 WHIRLPOOL d5125533261c163ebd006934d579f373e1f3b1b30da7e93e3196bbba01ea07010a5779464e1bb9138b94c908a448d287151f59bb4d6bd443b90308caa82e79e0
diff --git a/dev-vcs/github-pages-publish/github-pages-publish-0.1.ebuild b/dev-vcs/github-pages-publish/github-pages-publish-0.1.ebuild
new file mode 100644
index 000000000000..364ac39620e5
--- /dev/null
+++ b/dev-vcs/github-pages-publish/github-pages-publish-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/github-pages-publish/github-pages-publish-0.1.ebuild,v 1.1 2013/12/31 01:56:03 rafaelmartins Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+GIT_ECLASS=
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="git://github.com/rafaelmartins/github-pages-publish.git
+ https://github.com/rafaelmartins/github-pages-publish.git"
+fi
+
+inherit distutils-r1 ${GIT_ECLASS}
+
+DESCRIPTION="A script that commits files from a directory to Github Pages."
+HOMEPAGE="https://pypi.python.org/pypi/github-pages-publish
+ https://github.com/rafaelmartins/github-pages-publish"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pygit2-0.20.0
+ virtual/python-argparse"
+RDEPEND="${DEPEND}"
diff --git a/dev-vcs/github-pages-publish/metadata.xml b/dev-vcs/github-pages-publish/metadata.xml
new file mode 100644
index 000000000000..5af4bf893fec
--- /dev/null
+++ b/dev-vcs/github-pages-publish/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A script that commits files from a directory to the gh-pages branch
+ of the current Git repository.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="pypi">github-pages-publish</remote-id>
+ </upstream>
+</pkgmetadata>