summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-07 07:04:42 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-07 07:04:42 +0000
commit88b3cd1733a7e754955ac7558e916c27ae0d0dd1 (patch)
tree3a941b51b619ff70157a03d683ffbc6a2c0a5fc3 /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-88b3cd1733a7e754955ac7558e916c27ae0d0dd1.tar.gz
gentoo-2-88b3cd1733a7e754955ac7558e916c27ae0d0dd1.tar.bz2
gentoo-2-88b3cd1733a7e754955ac7558e916c27ae0d0dd1.zip
dev-vcs/hub: Install additional files
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hub/ChangeLog7
-rw-r--r--dev-vcs/hub/hub-1.12.2-r1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
index 6dd181f536b4..a6efd8691d4e 100644
--- a/dev-vcs/hub/ChangeLog
+++ b/dev-vcs/hub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.12 2014/08/14 13:53:39 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.13 2014/10/07 07:04:42 jlec Exp $
+
+*hub-1.12.2-r1 (07 Oct 2014)
+
+ 07 Oct 2014; Justin Lecher <jlec@gentoo.org> +hub-1.12.2-r1.ebuild:
+ Install additional files
14 Aug 2014; Manuel Rüger <mrueg@gentoo.org> hub-1.12.1.ebuild,
hub-1.12.2.ebuild:
diff --git a/dev-vcs/hub/hub-1.12.2-r1.ebuild b/dev-vcs/hub/hub-1.12.2-r1.ebuild
new file mode 100644
index 000000000000..7cd46db2d7d7
--- /dev/null
+++ b/dev-vcs/hub/hub-1.12.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.12.2-r1.ebuild,v 1.1 2014/10/07 07:04:42 jlec Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby19"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit bash-completion-r1 readme.gentoo ruby-fakegem
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ virtual/ruby-minitest
+ )"
+
+DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RDEPEND="dev-vcs/git"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+all_ruby_prepare() {
+ sed -i -e 's/Minitest/MiniTest/g' test/*.rb || die
+}
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+
+ cd "${S}"/all/${P} || die
+
+ doman man/${PN}.1
+
+ insinto /usr/share/${PN}/
+ doins -r git-hooks
+
+ # Broken with autoloader
+ # https://github.com/github/hub/issues/592
+ #newbashcomp etc/hub.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion ${PN}
+}