summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-02-22 14:28:04 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-02-22 14:28:04 +0000
commit8f8cefaf0cae9007f4ba6520eca927dde6d16ff8 (patch)
tree4ff91f60929b65694a21245903f3ae1dd3851dac /dev-vcs
parentarch stable, bug 888 (diff)
downloadgentoo-2-8f8cefaf0cae9007f4ba6520eca927dde6d16ff8.tar.gz
gentoo-2-8f8cefaf0cae9007f4ba6520eca927dde6d16ff8.tar.bz2
gentoo-2-8f8cefaf0cae9007f4ba6520eca927dde6d16ff8.zip
Version bump, also fixes bug 443738
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-deploy/ChangeLog10
-rw-r--r--dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild (renamed from dev-vcs/git-deploy/git-deploy-20120202.ebuild)30
2 files changed, 27 insertions, 13 deletions
diff --git a/dev-vcs/git-deploy/ChangeLog b/dev-vcs/git-deploy/ChangeLog
index dfbf9750720b..21a0171c5f5d 100644
--- a/dev-vcs/git-deploy/ChangeLog
+++ b/dev-vcs/git-deploy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-deploy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/ChangeLog,v 1.1 2012/02/10 20:27:25 idl0r Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/ChangeLog,v 1.2 2014/02/22 14:28:04 idl0r Exp $
+
+*git-deploy-6.0.1_p20131024 (22 Feb 2014)
+
+ 22 Feb 2014; Christian Ruppert <idl0r@gentoo.org>
+ +git-deploy-6.0.1_p20131024.ebuild, -git-deploy-20120202.ebuild:
+ Version bump, also fixes bug 443738
*git-deploy-20120202 (10 Feb 2012)
diff --git a/dev-vcs/git-deploy/git-deploy-20120202.ebuild b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
index f528aa354e9f..81a1286a9dd6 100644
--- a/dev-vcs/git-deploy/git-deploy-20120202.ebuild
+++ b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild
@@ -1,33 +1,39 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/git-deploy-20120202.ebuild,v 1.1 2012/02/10 20:27:25 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024.ebuild,v 1.1 2014/02/22 14:28:04 idl0r Exp $
-EAPI=4
+EAPI=5
inherit perl-app
+COMMIT="e9ef93debd12d85e70676dd79b4bd78ac2b05271"
+
DESCRIPTION="make deployments so easy that you'll let new hires do them on their
first day"
HOMEPAGE="https://github.com/git-deploy/git-deploy"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+COMMON_DEPEND="dev-vcs/git
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes
+ virtual/perl-Memoize
+ virtual/perl-Data-Dumper"
DEPEND="dev-lang/perl
test? (
- dev-vcs/git
+ ${COMMON_DEPEND}
virtual/perl-File-Temp
- perl-core/File-Spec
)"
RDEPEND="dev-lang/perl
- dev-vcs/git
- perl-core/File-Spec
- virtual/perl-Getopt-Long
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes"
+${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
src_prepare() {
pod2man -n git-deploy README.pod > git-deploy.1 || die
@@ -57,4 +63,6 @@ src_install() {
doins -r lib/Git
doman git-deploy.1
+
+ newdoc Changes ChangeLog
}