summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-14 20:54:33 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-14 20:54:33 +0000
commitecee6cbf9f3d66d0af39b4521d4aceacc65e6f1b (patch)
tree86a5f8f042bf9149155f5952c40677d97d676de7 /dev-vcs
parentversion bump and add avx useflags, bug #493986 (diff)
downloadgentoo-2-ecee6cbf9f3d66d0af39b4521d4aceacc65e6f1b.tar.gz
gentoo-2-ecee6cbf9f3d66d0af39b4521d4aceacc65e6f1b.tar.bz2
gentoo-2-ecee6cbf9f3d66d0af39b4521d4aceacc65e6f1b.zip
Version bump. Removed old
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog8
-rw-r--r--dev-vcs/git/git-1.8.5.3.ebuild (renamed from dev-vcs/git/git-1.8.5.1.ebuild)31
2 files changed, 34 insertions, 5 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 2f97e64e7dae..8e5bd749f079 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.238 2014/01/04 23:22:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.239 2014/01/14 20:54:33 polynomial-c Exp $
+
+*git-1.8.5.3 (14 Jan 2014)
+
+ 14 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> -git-1.8.5.1.ebuild,
+ +git-1.8.5.3.ebuild:
+ Version bump. Removed old.
04 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org> git-1.8.5.2.ebuild,
git-9999.ebuild:
diff --git a/dev-vcs/git/git-1.8.5.1.ebuild b/dev-vcs/git/git-1.8.5.3.ebuild
index 9262d6cd852d..5a719d821990 100644
--- a/dev-vcs/git/git-1.8.5.1.ebuild
+++ b/dev-vcs/git/git-1.8.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.5.1.ebuild,v 1.2 2013/12/11 10:27:22 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.5.3.ebuild,v 1.1 2014/01/14 20:54:33 polynomial-c Exp $
EAPI=5
@@ -40,14 +40,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv mediawiki +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
dev-libs/openssl
sys-libs/zlib
pcre? ( dev-libs/libpcre )
- perl? ( dev-lang/perl[-build(-)] )
+ perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
@@ -58,6 +58,10 @@ CDEPEND="
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
+ mediawiki? (
+ dev-perl/HTML-Tree
+ dev-perl/MediaWiki-API
+ )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
@@ -100,6 +104,7 @@ S="${WORKDIR}/${MY_P}"
REQUIRED_USE="
cgi? ( perl )
cvs? ( perl )
+ mediawiki? ( perl )
subversion? ( perl )
webdav? ( curl )
gtk? ( python )
@@ -222,6 +227,13 @@ src_prepare() {
# bug #350330 - automagic CVS when we don't want it is bad.
epatch "${FILESDIR}"/git-1.8.5-optional-cvs.patch
+ # honor and correctly quote DISTDIR (from upstream git master)
+ epatch "${FILESDIR}"/git-1.8.5-mw-destdir.patch
+
+ # install mediawiki perl modules also in vendor_dir
+ # hack, needs better upstream solution
+ epatch "${FILESDIR}"/git-1.8.5-mw-vendor.patch
+
sed -i \
-e 's:^\(CFLAGS[[:space:]]*=\).*$:\1 $(OPTCFLAGS) -Wall:' \
-e 's:^\(LDFLAGS[[:space:]]*=\).*$:\1 $(OPTLDFLAGS):' \
@@ -329,6 +341,11 @@ src_compile() {
cd "${S}"/contrib/subtree
git_emake
use doc && git_emake doc
+
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake
+ fi
}
src_install() {
@@ -390,6 +407,12 @@ src_install() {
dodoc git-subtree.txt
cd "${S}"
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake install
+ cd "${S}"
+ fi
+
# git-diffall
dobin contrib/diffall/git-diffall
newdoc contrib/diffall/README git-diffall.txt