summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-07-24 19:22:22 +0000
committerFabian Groffen <grobian@gentoo.org>2012-07-24 19:22:22 +0000
commit008adeb27e0e5aaee0147812cc7843b51082bdc8 (patch)
tree5c931aaa02191f19f498fbd8a97864eef1a9f976 /eclass/autotools.eclass
parentRemove /etc/make.globals symlink code (bug #427862). (diff)
downloadgentoo-2-008adeb27e0e5aaee0147812cc7843b51082bdc8.tar.gz
gentoo-2-008adeb27e0e5aaee0147812cc7843b51082bdc8.tar.bz2
gentoo-2-008adeb27e0e5aaee0147812cc7843b51082bdc8.zip
_elibtoolize: properly set LIBTOOLIZE in case glibtoolize exists in the system, bug #418465
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass5
1 files changed, 2 insertions, 3 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index e1da7a156b81..e5d7612f6e23 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.147 2012/06/08 04:55:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.148 2012/07/24 19:22:22 grobian Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -292,8 +292,7 @@ eaclocal() {
#
# Note the '_' prefix .. to not collide with elibtoolize() from libtool.eclass.
_elibtoolize() {
- local LIBTOOLIZE=${LIBTOOLIZE:-libtoolize}
- type -P glibtoolize > /dev/null && LIBTOOLIZE=glibtoolize
+ local LIBTOOLIZE=${LIBTOOLIZE:-$(type -P glibtoolize > /dev/null && echo glibtoolize || echo libtoolize)}
[[ -f GNUmakefile.am || -f Makefile.am ]] && set -- "$@" --automake
if [[ $1 == "--install" ]] ; then