summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-03-28 22:20:13 +0000
committerDan Armak <danarmak@gentoo.org>2002-03-28 22:20:13 +0000
commita3961a1276ff8ef2dc555acdb4e017a7850e92e1 (patch)
treefa2ad0e65353640de9971ddbc00d1d7b7ad2c9a6 /eclass/kde-functions.eclass
parentVersion bump (diff)
downloadgentoo-2-a3961a1276ff8ef2dc555acdb4e017a7850e92e1.tar.gz
gentoo-2-a3961a1276ff8ef2dc555acdb4e017a7850e92e1.tar.bz2
gentoo-2-a3961a1276ff8ef2dc555acdb4e017a7850e92e1.zip
fix for the kde3/autoconf problem, see gentoo-user post, thanks Azarah!
also: moved kde-sandbox-patch() from kde.eclass de-functions.eclass where it belongs also: update kde3 apps' qt dep from 3.0.1 to 3.0.3
Diffstat (limited to 'eclass/kde-functions.eclass')
-rw-r--r--eclass/kde-functions.eclass40
1 files changed, 38 insertions, 2 deletions
diff --git a/eclass/kde-functions.eclass b/eclass/kde-functions.eclass
index dc804da7af6b..f99f74925cd3 100644
--- a/eclass/kde-functions.eclass
+++ b/eclass/kde-functions.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.1 2002/03/27 23:52:40 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.2 2002/03/28 22:20:13 danarmak Exp $
# This contains everything except things that modify ebuild variables and functions (e.g. $P, src_compile() etc.)
ECLASS=kde-functions
@@ -28,6 +28,14 @@ set-kdedir() {
debug-print-function $FUNCNAME $*
+ # something's wrong with my writing an if for this
+ case "$1" in
+ 3*)
+ export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOMAKE_1_4=1
+ ;;
+ esac
+
# default settings for older make.globals versions which don't include the default KDE?DIR settings
[ -z "$KDE2DIR" ] && export KDE2DIR="/usr/kde/2"
[ -z "$KDE3DIR" ] && export KDE3DIR="/usr/kde/3"
@@ -90,7 +98,7 @@ qtver-from-kdever() {
case $1 in
2*) ver=2.3.1;;
- 3*) ver=3.0.1;;
+ 3*) ver=3.0.3;;
*) echo "!!! error: $FUNCNAME() called with invalid parameter: \"$1\", please report bug" && exit 1;;
esac
@@ -134,3 +142,31 @@ min-qt-ver() {
}
+
+# generic makefile sed for sandbox compatibility. for some reason when the kde makefiles (of many packages
+# and versions) try to chown root and chmod 4755 some binaries (after installing, target isntall-exec-local),
+# they do it to the files in $(bindir), not $(DESTDIR)/$(bindir). I've fild a report on bugs.kde.org but no
+# response so far.
+# Pass a list of dirs to sed, Makefile.{am,in} in these dirs will be sed'ed.
+# This should be harmless if the makefile doesn't need fixing.
+kde_sandbox_patch() {
+
+ debug-print-function $FUNCNAME $*
+
+ while [ -n "$1" ]; do
+ # can't use dosed, because it only works for things in ${D}, not ${S}
+ cd $1
+ for x in Makefile.am Makefile.in Makefile
+ do
+ if [ -f "$x" ]; then
+ echo Running sed on $x
+ cp $x ${x}.orig
+ sed -e 's: $(bindir): $(DESTDIR)/$(bindir):g' -e 's: $(kde_datadir): $(DESTDIR)/$(kde_datadir):g' ${x}.orig > ${x}
+ rm ${x}.orig
+ fi
+ done
+ shift
+ done
+
+}
+