summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-05-12 17:59:02 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-05-12 17:59:02 +0000
commitfdc0b273a477b76850a2a13cdeea3fc8e6693469 (patch)
treeb89a928a2c4047ef7684297cb1d4fbf481f7e966 /eclass/virtuoso.eclass
parentx86 stable wrt bug #316643 (diff)
downloadgentoo-2-fdc0b273a477b76850a2a13cdeea3fc8e6693469.tar.gz
gentoo-2-fdc0b273a477b76850a2a13cdeea3fc8e6693469.tar.bz2
gentoo-2-fdc0b273a477b76850a2a13cdeea3fc8e6693469.zip
Replace grep -P with more portable sed -ne equivalent
Diffstat (limited to 'eclass/virtuoso.eclass')
-rw-r--r--eclass/virtuoso.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/virtuoso.eclass b/eclass/virtuoso.eclass
index 4c6fe16d6851..6622bf0ce7af 100644
--- a/eclass/virtuoso.eclass
+++ b/eclass/virtuoso.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/virtuoso.eclass,v 1.3 2010/04/06 17:28:31 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/virtuoso.eclass,v 1.4 2010/05/12 17:59:02 reavertm Exp $
# @ECLASS: virtuoso.eclass
# @MAINTAINER:
@@ -89,7 +89,7 @@ virtuoso_src_prepare() {
sed -e '/^# DISABLED \s*SUBDIRS\s*=/s/.*/SUBDIRS =/g' \
-i "${path}"/Makefile.am
# Append subdirs if not there already
- if [[ -z `grep --color=never -P "SUBDIRS\s*=.*${subdir}\b" "${path}"/Makefile.am` ]]; then
+ if [[ -z `sed -ne "/SUBDIRS\s*=.*${subdir}\b/p" "${path}"/Makefile.am` ]]; then
sed -e "/^SUBDIRS\s*=/s|$| ${subdir}|" \
-i "${path}"/Makefile.am || die "failed to append ${subdir}"
fi