summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-04-13 21:46:44 +0000
committerDan Armak <danarmak@gentoo.org>2003-04-13 21:46:44 +0000
commit529d005418dc3440b0751184be6b6ca6ab644972 (patch)
tree57d9491246e3c401ce55d84cde7cfdc66cc48768 /eclass
parentRemoved daily snapshop as new version is out. (diff)
downloadgentoo-2-529d005418dc3440b0751184be6b6ca6ab644972.tar.gz
gentoo-2-529d005418dc3440b0751184be6b6ca6ab644972.tar.bz2
gentoo-2-529d005418dc3440b0751184be6b6ca6ab644972.zip
do not run make -f $makefile if $makefile is empty
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde.eclass10
1 files changed, 6 insertions, 4 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index 762159ed4ae7..32b180481e22 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.77 2003/04/02 10:46:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.78 2003/04/13 21:46:44 danarmak Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -98,10 +98,12 @@ kde_src_compile() {
# This can happen with e.g. a cvs snapshot
if [ ! -f "./configure" ]; then
for x in Makefile.cvs admin/Makefile.common; do
- if [ -f "$x" ] && [ -z "$makefile" ]; then makefile="$x"; fi
+ if [ -f "$x" ] && [ -z "$makefile" ]; then makefile="$x"; fi
done
- debug-print "$FUNCNAME: configure: generating configure script, running make -f $makefile"
- make -f $makefile
+ if [ -f "$makefile" ]; then
+ debug-print "$FUNCNAME: configure: generating configure script, running make -f $makefile"
+ make -f $makefile
+ fi
[ -f "./configure" ] || die "no configure script found, generation unsuccessful"
fi