summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-05 15:15:32 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-05 15:15:32 +0000
commite4980d27397f69d9dfdd1a7c945bd5730a8a52ef (patch)
treec8f7e490559bdd5fb0b573ff4bc29560e4c794a1 /eclass
parentVersion bump. (diff)
downloadgentoo-2-e4980d27397f69d9dfdd1a7c945bd5730a8a52ef.tar.gz
gentoo-2-e4980d27397f69d9dfdd1a7c945bd5730a8a52ef.tar.bz2
gentoo-2-e4980d27397f69d9dfdd1a7c945bd5730a8a52ef.zip
Fix enabling byte-compiling.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass5
2 files changed, 7 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index d66751c1acbc..a7f5f0a54e30 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.499 2012/11/04 15:16:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.500 2012/11/05 15:15:32 mgorny Exp $
+
+ 05 Nov 2012; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Fix enabling byte-compiling.
04 Nov 2012; Michał Górny <mgorny@gentoo.org> python-r1.eclass:
Always require PYTHON_COMPAT. Add an exception for python-exec which is a
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 7a62761a397e..bafa6239ff7f 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.17 2012/11/01 12:19:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.18 2012/11/05 15:15:32 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -281,7 +281,8 @@ distutils-r1_python_install() {
debug-print "${FUNCNAME}: [${EPYTHON}] flags: ${flags}"
# enable compilation for the install phase.
- local PYTHONDONTWRITEBYTECODE=
+ local PYTHONDONTWRITEBYTECODE
+ export PYTHONDONTWRITEBYTECODE
esetup.py install "${flags[@]}" --root="${D}" "${@}"