summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-13 13:04:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-13 13:04:17 +0000
commita8b3079f43322ca657ca2d823714228bfea881e3 (patch)
tree9fc749adc1f9a26e819270401fc92f2285bee0b8 /games-action/noiz2sa/noiz2sa-0.51a.ebuild
parentStable on sparc wrt #70825 (Manifest recommit) (diff)
downloadgentoo-2-a8b3079f43322ca657ca2d823714228bfea881e3.tar.gz
gentoo-2-a8b3079f43322ca657ca2d823714228bfea881e3.tar.bz2
gentoo-2-a8b3079f43322ca657ca2d823714228bfea881e3.zip
initial commit - ebuild submitted by Atzm Watanabe via bug #53227
Diffstat (limited to 'games-action/noiz2sa/noiz2sa-0.51a.ebuild')
-rw-r--r--games-action/noiz2sa/noiz2sa-0.51a.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-action/noiz2sa/noiz2sa-0.51a.ebuild b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
new file mode 100644
index 000000000000..585c20b75b6d
--- /dev/null
+++ b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/noiz2sa/noiz2sa-0.51a.ebuild,v 1.1 2004/12/13 13:04:17 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Abstract Shooting Game"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/noiz2sa_e.html http://sourceforge.net/projects/noiz2sa/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-mixer
+ >=dev-libs/libbulletml-0.0.3
+ virtual/opengl"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}/src"
+ sed -e "s/-lglut/-lGL/" makefile.lin > Makefile || die "sed failed"
+
+ sed -i \
+ -e "s:/.noiz2sa.prf:/noiz2sa.prf:" \
+ -e "s:getenv(\"HOME\"):\"${GAMES_STATEDIR}\":" \
+ attractmanager.c \
+ || die "sed failed"
+}
+
+src_compile(){
+ emake -C src MORE_CFLAGS="${CFLAGS}" || die
+}
+
+src_install(){
+ local datadir="${GAMES_DATADIR}/${PN}"
+
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ dodir "${datadir}" "${GAMES_STATEDIR}"
+ cp -r noiz2sa_share/* "${D}/${datadir}" || die "cp failed"
+ dodoc readme*
+ touch "${D}${GAMES_STATEDIR}/${PN}.prf"
+ fperms 660 "${GAMES_STATEDIR}/${PN}.prf"
+ prepgamesdirs
+}