summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 13:18:37 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 13:18:37 +0000
commitc69aa030ca1f07b9e01dcfa8ebc11a8e2014fea0 (patch)
tree051d04a742ff7f358b61f8ee1f19625310e01ce1 /games-action/shadowgrounds-survivor-bin
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-c69aa030ca1f07b9e01dcfa8ebc11a8e2014fea0.tar.gz
gentoo-2-c69aa030ca1f07b9e01dcfa8ebc11a8e2014fea0.tar.bz2
gentoo-2-c69aa030ca1f07b9e01dcfa8ebc11a8e2014fea0.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/shadowgrounds-survivor-bin')
-rw-r--r--games-action/shadowgrounds-survivor-bin/ChangeLog10
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11-r1.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/games-action/shadowgrounds-survivor-bin/ChangeLog b/games-action/shadowgrounds-survivor-bin/ChangeLog
index 9872c79e0b10..19bf77862835 100644
--- a/games-action/shadowgrounds-survivor-bin/ChangeLog
+++ b/games-action/shadowgrounds-survivor-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/shadowgrounds-survivor-bin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/ChangeLog,v 1.3 2013/03/29 15:36:41 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/ChangeLog,v 1.4 2014/06/25 13:18:37 mgorny Exp $
+
+*shadowgrounds-survivor-bin-0_beta11-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +shadowgrounds-survivor-bin-0_beta11-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
29 Mar 2013; Julian Ospald <hasufell@gentoo.org>
shadowgrounds-survivor-bin-0_beta11.ebuild:
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11-r1.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11-r1.ebuild
new file mode 100644
index 000000000000..212b2d2021f8
--- /dev/null
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11-r1.ebuild,v 1.1 2014/06/25 13:18:37 mgorny Exp $
+
+EAPI=5
+
+inherit unpacker games eutils
+
+DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
+HOMEPAGE="http://shadowgroundsgame.com/survivor/"
+SRC_URI="Survivor${PV/*_b/B}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0
+ !amd64? (
+ gnome-base/libglade
+ )
+ amd64? (
+ || (
+ app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ gnome-base/libglade[abi_x86_32(-)]
+ )
+ )"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unpack_zip ${A}
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Survivor.xpm || die
+ for b in bin launcher ; do
+ bb="survivor-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb}
+ games_make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Shadowgrounds Survivor ${b}" "Shadowgrounds Survivor"
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/*
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png
+
+ prepgamesdirs
+}