summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-04-10 06:30:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-04-10 06:30:58 +0000
commita95bd487bcc35694b493e0ccbc1272932c75c1bf (patch)
treefbf70bae90743f71983ed893f2bf58a16a48c2a9 /games-action/shootingstar
parentbump; radical updating that goes with adding py3 pypy support and conversion ... (diff)
downloadgentoo-2-a95bd487bcc35694b493e0ccbc1272932c75c1bf.tar.gz
gentoo-2-a95bd487bcc35694b493e0ccbc1272932c75c1bf.tar.bz2
gentoo-2-a95bd487bcc35694b493e0ccbc1272932c75c1bf.zip
fix up HOMEPAGE,SRC_URI (bug #499702); EAPI=5; improve icon handling
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action/shootingstar')
-rw-r--r--games-action/shootingstar/ChangeLog9
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild44
2 files changed, 36 insertions, 17 deletions
diff --git a/games-action/shootingstar/ChangeLog b/games-action/shootingstar/ChangeLog
index 657411b5c1cb..5746a197721c 100644
--- a/games-action/shootingstar/ChangeLog
+++ b/games-action/shootingstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/shootingstar
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.7 2009/10/19 05:01:04 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.8 2014/04/10 06:30:58 mr_bones_ Exp $
+
+ 10 Apr 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ shootingstar-1.2.0.ebuild:
+ fix up HOMEPAGE,SRC_URI (bug #499702); EAPI=5; improve icon handling
19 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
shootingstar-1.2.0.ebuild:
@@ -26,4 +30,3 @@
23 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
shootingstar-1.2.0.ebuild:
initial commit; ebuild submitted by Thomas Preissler via bug #42569 (modified)
-
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
index b9f9ab684d85..924c2badbe28 100644
--- a/games-action/shootingstar/shootingstar-1.2.0.ebuild
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.7 2009/10/19 05:01:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.8 2014/04/10 06:30:58 mr_bones_ Exp $
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit autotools eutils gnome2-utils games
DESCRIPTION="A topdown shooter"
-HOMEPAGE="http://www.2ndpoint.fi/ss"
-SRC_URI="http://www.2ndpoint.fi/ss/${P}.tar.gz"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
DEPEND="virtual/opengl
@@ -19,16 +19,32 @@ DEPEND="virtual/opengl
media-libs/libsdl[video]
media-libs/sdl-mixer
media-libs/sdl-image"
+RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PV}-gcc34.patch
- "${FILESDIR}"/${P}-gcc44.patch
-)
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-gcc34.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+ eautoreconf
+}
src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newicon data/textures/body1.png ${PN}.png
+ default
+ newicon -s 128 data/textures/body1.png ${PN}.png
make_desktop_entry ${PN} "Shooting Star"
- dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}