summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-16 06:33:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-16 06:33:01 +0000
commit7b8bd77390d1995a76c5c88c61f41ca2007ca930 (patch)
tree39e2c27de39370bdae51dafbb26304a44c4c5415 /games-action
parentBumping to fix doc install bug (diff)
downloadgentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.tar.gz
gentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.tar.bz2
gentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.zip
add bounds patch from Ewgenij Starostin (bug #197556); QA fixes; patch name standardizing
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/0verkill/0verkill-0.16-r3.ebuild18
-rw-r--r--games-action/0verkill/ChangeLog12
-rw-r--r--games-action/0verkill/files/0verkill-0.16-docs.patch (renamed from games-action/0verkill/files/0.16-docs.patch)0
-rw-r--r--games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch (renamed from games-action/0verkill/files/0.16-gentoo-paths.patch)14
-rw-r--r--games-action/0verkill/files/0verkill-0.16-home-overflow.patch (renamed from games-action/0verkill/files/0.16-home-overflow.patch)0
-rw-r--r--games-action/0verkill/files/0verkill-0.16-segv.patch39
6 files changed, 72 insertions, 11 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r3.ebuild b/games-action/0verkill/0verkill-0.16-r3.ebuild
index 870fd36065b5..e01ef08c8996 100644
--- a/games-action/0verkill/0verkill-0.16-r3.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.3 2007/08/08 22:02:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.4 2007/11/16 06:33:01 mr_bones_ Exp $
-inherit eutils games
+inherit autotools eutils games
DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
@@ -18,16 +18,22 @@ DEPEND="X? ( x11-libs/libXpm )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-docs.patch
- epatch "${FILESDIR}"/${PV}-home-overflow.patch
- epatch "${FILESDIR}"/${PV}-gentoo-paths.patch
- epatch "${FILESDIR}"/${P}-underflow-check.patch #136222
+ epatch \
+ "${FILESDIR}"/${P}-docs.patch \
+ "${FILESDIR}"/${P}-home-overflow.patch \
+ "${FILESDIR}"/${P}-segv.patch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-underflow-check.patch #136222
sed -i \
-e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h \
|| die "sed failed"
sed -i \
-e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in \
|| die "sed failed"
+ sed -i \
+ -e "/gettimeofday/s/getopt/getopt calloc/" configure.in \
+ || die "sed failed"
+ eautoreconf
}
src_compile() {
diff --git a/games-action/0verkill/ChangeLog b/games-action/0verkill/ChangeLog
index 588745cdcab6..289820656187 100644
--- a/games-action/0verkill/ChangeLog
+++ b/games-action/0verkill/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-action/0verkill
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.14 2006/12/01 19:49:07 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.15 2007/11/16 06:33:01 mr_bones_ Exp $
+
+ 16 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0verkill-0.16-docs.patch, -files/0.16-docs.patch,
+ +files/0verkill-0.16-gentoo-paths.patch, -files/0.16-gentoo-paths.patch,
+ +files/0verkill-0.16-home-overflow.patch, -files/0.16-home-overflow.patch,
+ +files/0verkill-0.16-segv.patch, 0verkill-0.16-r3.ebuild:
+ add bounds patch from Ewgenij Starostin (bug #197556); QA fixes; patch name
+ standardizing
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
0verkill-0.16-r3.ebuild:
diff --git a/games-action/0verkill/files/0.16-docs.patch b/games-action/0verkill/files/0verkill-0.16-docs.patch
index 90d049309f4d..90d049309f4d 100644
--- a/games-action/0verkill/files/0.16-docs.patch
+++ b/games-action/0verkill/files/0verkill-0.16-docs.patch
diff --git a/games-action/0verkill/files/0.16-gentoo-paths.patch b/games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch
index 63b77e0ffb7e..a5ecaec01684 100644
--- a/games-action/0verkill/files/0.16-gentoo-paths.patch
+++ b/games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch
@@ -1,6 +1,14 @@
---- sprite.c.orig 2004-01-08 00:42:51.897946128 -0500
-+++ sprite.c 2004-01-08 00:43:10.986044296 -0500
-@@ -188,6 +188,12 @@
+--- sprite.c.orig 2007-11-15 18:26:30.000000000 -0500
++++ sprite.c 2007-11-15 18:26:57.000000000 -0500
+@@ -2,6 +2,7 @@
+ #include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <unistd.h>
+
+ #ifndef WIN32
+ #include "config.h"
+@@ -188,6 +189,12 @@
if (!(f=fopen(filename,"rb")))
{
diff --git a/games-action/0verkill/files/0.16-home-overflow.patch b/games-action/0verkill/files/0verkill-0.16-home-overflow.patch
index ec9b7efb36e7..ec9b7efb36e7 100644
--- a/games-action/0verkill/files/0.16-home-overflow.patch
+++ b/games-action/0verkill/files/0verkill-0.16-home-overflow.patch
diff --git a/games-action/0verkill/files/0verkill-0.16-segv.patch b/games-action/0verkill/files/0verkill-0.16-segv.patch
new file mode 100644
index 000000000000..9f9656dfd9fa
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-segv.patch
@@ -0,0 +1,39 @@
+diff -Naurp 0verkill-0.16.old/data.c 0verkill-0.16/data.c
+--- 0verkill-0.16.old/data.c 2007-10-30 19:49:59.000000000 +0100
++++ 0verkill-0.16/data.c 2007-10-30 20:25:08.000000000 +0100
+@@ -471,7 +471,7 @@ my_double can_go_x(my_double old_x,my_do
+ for (x=double2int(old_x)+1;x<=round_up(new_x);x++) /* go to the right */
+ {
+ if (x>AREA_X-1) return int2double(AREA_X-1);
+- for (y=yh;y<=yl;y++)
++ for (y=(yh>=0?yh:0);y<=yl;y++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL)
+ return int2double(x-1);
+ }
+@@ -479,7 +479,7 @@ my_double can_go_x(my_double old_x,my_do
+ for (x=round_up(old_x)-1;x>=double2int(new_x);x--) /* go to the left */
+ {
+ if (x<0) return 0;
+- for (y=yh;y<=yl;y++)
++ for (y=(yh>=0?yh:0);y<=yl;y++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL) return int2double(x+1);
+ }
+ if(flag)*flag=0;
+@@ -501,7 +501,7 @@ my_double can_go_y(my_double old_y, my_d
+ for (y=double2int(old_y)+1;y<=round_up(new_y);y++) /* go down */
+ {
+ if (y>AREA_Y-1) return int2double(AREA_Y-1);
+- for (x=xl;x<=xr;x++)
++ for (x=(xl>=0?xl:0);x<=xr;x++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL||(!down_ladder&&((area_a[x+y*AREA_X]&240)==TYPE_JUMP||(area_a[x+y*AREA_X]&240)==TYPE_JUMP_FOREGROUND))) return int2double(y-1);
+ }
+ else
+@@ -510,7 +510,7 @@ my_double can_go_y(my_double old_y, my_d
+ for (y=round_up(old_y)-1;y>=double2int(new_y);y--) /* go up */
+ {
+ if (y<0) return 0;
+- for (x=xl;x<=xr;x++)
++ for (x=(xl>=0?xl:0);x<=xr;x++)
+ if ((area_a[x+y*AREA_X]&240)==TYPE_WALL) return int2double(y+1);
+ }
+ }