summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-04 21:28:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-04 21:28:42 +0000
commitf013a7cd911f0754850a90c60d0f0380a56e5a0d (patch)
tree3cd20b957dc4aa828e43f6dae60c893eb6eb8b6a /games-arcade/abe/abe-1.1.ebuild
parentBump KDE 4.2.1 (diff)
downloadgentoo-2-f013a7cd911f0754850a90c60d0f0380a56e5a0d.tar.gz
gentoo-2-f013a7cd911f0754850a90c60d0f0380a56e5a0d.tar.bz2
gentoo-2-f013a7cd911f0754850a90c60d0f0380a56e5a0d.zip
EAPI=2; add settings patch from Pacho Ramos (bug #261222)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-arcade/abe/abe-1.1.ebuild')
-rw-r--r--games-arcade/abe/abe-1.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/games-arcade/abe/abe-1.1.ebuild b/games-arcade/abe/abe-1.1.ebuild
index 2258c4d99cde..8f8173bf0fe8 100644
--- a/games-arcade/abe/abe-1.1.ebuild
+++ b/games-arcade/abe/abe-1.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.6 2008/01/05 04:01:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.7 2009/03/04 21:28:38 mr_bones_ Exp $
+EAPI=2
inherit eutils toolchain-funcs games
DESCRIPTION="A scrolling, platform-jumping, key-collecting, ancient pyramid exploring game"
@@ -15,22 +16,25 @@ IUSE=""
DEPEND="media-libs/libsdl
x11-libs/libXi
- media-libs/sdl-mixer"
+ media-libs/sdl-mixer[vorbis]"
src_unpack() {
unpack ${A}
cd "${S}"
+ unpack ./images/images.tar
+}
+
+src_prepare() {
sed -i \
-e "/^TR_CFLAGS/d" \
-e "/^TR_CXXFLAGS/d" \
configure \
|| die "sed failed"
- unpack ./images/images.tar
+ epatch "${FILESDIR}"/${P}-settings.patch
}
-src_compile() {
- egamesconf --with-data-dir="${GAMES_DATADIR}"/${PN} || die
- emake CC=$(tc-getCC) || die "emake failed"
+src_configure() {
+ egamesconf --with-data-dir="${GAMES_DATADIR}"/${PN}
}
src_install() {