summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-08 01:02:10 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-08 01:02:10 +0000
commitf7615ffa1c7c3ccee6ac320aa48ee6bc84af4dd5 (patch)
treec8d8219bd9c40b1bbe2ffde7279852daab25925a /games-arcade/bub-n-bros
parentversion bump as per bug #181263 thanks cilly (diff)
downloadgentoo-2-f7615ffa1c7c3ccee6ac320aa48ee6bc84af4dd5.tar.gz
gentoo-2-f7615ffa1c7c3ccee6ac320aa48ee6bc84af4dd5.tar.bz2
gentoo-2-f7615ffa1c7c3ccee6ac320aa48ee6bc84af4dd5.zip
Version bump by Tomasz Mon, bug #78823
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-arcade/bub-n-bros')
-rw-r--r--games-arcade/bub-n-bros/ChangeLog8
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild59
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch51
-rw-r--r--games-arcade/bub-n-bros/files/digest-bub-n-bros-1.53
4 files changed, 120 insertions, 1 deletions
diff --git a/games-arcade/bub-n-bros/ChangeLog b/games-arcade/bub-n-bros/ChangeLog
index 9d3b71e21c7c..e0c5e4ec39b6 100644
--- a/games-arcade/bub-n-bros/ChangeLog
+++ b/games-arcade/bub-n-bros/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/bub-n-bros
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.11 2007/04/09 21:51:09 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/ChangeLog,v 1.12 2007/06/08 01:02:10 nyhm Exp $
+
+*bub-n-bros-1.5 (08 Jun 2007)
+
+ 08 Jun 2007; <tristan@gentoo.org> +files/bub-n-bros-1.5-home.patch,
+ +bub-n-bros-1.5.ebuild:
+ Version bump by Tomasz Mon, bug #78823
09 Apr 2007; Peter Weller <welp@gentoo.org> bub-n-bros-1.1.ebuild:
Keyworded ~x86-fbsd wrt bug 173405
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild
new file mode 100644
index 000000000000..7d114a2b543e
--- /dev/null
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild,v 1.1 2007/06/08 01:02:10 nyhm Exp $
+
+inherit eutils games
+
+MY_P=${P/-n-}
+DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
+HOMEPAGE="http://bub-n-bros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="dev-python/pygame"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-home.patch
+}
+
+src_compile() {
+ # Compile the "statesaver" extension module to enable the Clock bonus
+ cd "${S}"/bubbob
+ python setup.py build_ext -i || die
+
+ # Compile the extension module required for the X Window client
+ cd "${S}"/display
+ python setup.py build_ext -i || die
+
+ # Build images
+ cd "${S}"/bubbob/images
+ python buildcolors.py || die
+}
+
+src_install() {
+ local dir=$(games_get_libdir)/${PN}
+
+ exeinto "${dir}"
+ doexe *.py || die "doexe failed"
+
+ insinto "${dir}"
+ doins -r bubbob common display java http2 metaserver || die "doins failed"
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/BubBob.py "${GAMES_BINDIR}"/bubnbros || die "dosym failed"
+
+ newicon http2/data/bob.png ${PN}.png
+ make_desktop_entry bubnbros Bub-n-Bros
+
+ rm -rf $(find "${D}/${dir}" -name CVS -type d)
+ prepgamesdirs
+}
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch
new file mode 100644
index 000000000000..a52dc15c0e16
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch
@@ -0,0 +1,51 @@
+--- bubbob/images.py
++++ bubbob/images.py
+@@ -427,7 +427,6 @@
+ # check and maybe regenerate the colored image files
+ file = os.path.join('images', 'buildcolors.py')
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+ # replace the entries 'filename_%d.ppm' by a family of entries,
+ # one for each color
+ sprmap = {}
+--- display/pclient.py
++++ display/pclient.py
+@@ -155,8 +155,8 @@
+ if mode[-1].has_key('cfgfile'):
+ self.trackcfgfile = mode[-1]['cfgfile']
+ else:
+- self.trackcfgfile = os.path.join(DataChunk.SOURCEDIR,
+- 'http2', 'config.txt')
++ self.trackcfgfile = os.path.join(os.environ.get('HOME'),
++ '.bubnbros')
+ self.udpsock = None
+ self.udpsock_low = None
+ self.udpsock2 = None
+--- http2/httppages.py
++++ http2/httppages.py
+@@ -38,7 +38,7 @@
+
+
+ class PageServer:
+- CONFIGFILE = 'config.txt'
++ CONFIGFILE = '.bubnbros'
+ localservers = None
+
+ def __init__(self, Game):
+@@ -46,7 +46,7 @@
+ self.seed = hex(random.randrange(0x1000, 0x10000))
+ #self.unique_actions = {}
+ self.localhost = gamesrv.HOSTNAME
+- self.filename = os.path.join(LOCALDIR, self.CONFIGFILE)
++ self.filename = os.path.join(os.environ.get('HOME'), self.CONFIGFILE)
+ data = self.loadoptionfile()
+ self.globaloptions = Options(data.get('*', {}))
+ self.localoptions = Options(data.get(self.localhost, {}))
+@@ -336,7 +336,6 @@
+ 'buildcolors.py')
+ if os.path.exists(file):
+ g = {'__name__': '__auto__', '__file__': file}
+- execfile(file, g)
+
+ if port:
+ address = '%s:%s' % (host, port)
diff --git a/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5 b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5
new file mode 100644
index 000000000000..c0d86d4cad44
--- /dev/null
+++ b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5
@@ -0,0 +1,3 @@
+MD5 431fd06ba7f838f61c9200e291060365 bubbros-1.5.tar.bz2 8856240
+RMD160 dafe5004569ed4313d0e470627337810fefec820 bubbros-1.5.tar.bz2 8856240
+SHA256 91db9aa59f2adcd6f79cff475b457901aea82ffe0ebc557012eb3a0a36a3b05b bubbros-1.5.tar.bz2 8856240