summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-13 16:25:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-13 16:25:54 +0000
commit447c113cc33e74cb0d55f2fe33acb162a2dfe2a6 (patch)
tree9f3d921fc9c2e4e5e8ac2cc554368a41693be7da /games-arcade/ceferino
parentamd64 stable, bug #269591 (diff)
downloadgentoo-2-447c113cc33e74cb0d55f2fe33acb162a2dfe2a6.tar.gz
gentoo-2-447c113cc33e74cb0d55f2fe33acb162a2dfe2a6.tar.bz2
gentoo-2-447c113cc33e74cb0d55f2fe33acb162a2dfe2a6.zip
EAPI=2; add gcc44 patch submitted by Oschtan via bug #269678
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'games-arcade/ceferino')
-rw-r--r--games-arcade/ceferino/ChangeLog8
-rw-r--r--games-arcade/ceferino/ceferino-0.97.8.ebuild29
-rw-r--r--games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch11
3 files changed, 33 insertions, 15 deletions
diff --git a/games-arcade/ceferino/ChangeLog b/games-arcade/ceferino/ChangeLog
index c77b0b9305b3..5ee89816e0cf 100644
--- a/games-arcade/ceferino/ChangeLog
+++ b/games-arcade/ceferino/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/ceferino
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ceferino/ChangeLog,v 1.12 2007/08/16 00:51:36 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ceferino/ChangeLog,v 1.13 2009/05/13 16:25:54 mr_bones_ Exp $
+
+ 13 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ceferino-0.97.8-gcc44.patch, ceferino-0.97.8.ebuild:
+ EAPI=2; add gcc44 patch submitted by Oschtan via bug #269678
*ceferino-0.97.8 (16 Aug 2007)
diff --git a/games-arcade/ceferino/ceferino-0.97.8.ebuild b/games-arcade/ceferino/ceferino-0.97.8.ebuild
index 0ec80069b359..4ccd9bfb2f5c 100644
--- a/games-arcade/ceferino/ceferino-0.97.8.ebuild
+++ b/games-arcade/ceferino/ceferino-0.97.8.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ceferino/ceferino-0.97.8.ebuild,v 1.1 2007/08/16 00:51:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ceferino/ceferino-0.97.8.ebuild,v 1.2 2009/05/13 16:25:54 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
@@ -20,22 +21,24 @@ RDEPEND=">=media-libs/libsdl-1.2
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i '/^\(gnu\)\?localedir /s:= .*:= /usr/share/locale:' \
- po/Makefile.in.in || die "sed failed"
- sed -i '/^INCLUDES/s:\$(datadir)/locale:/usr/share/locale:' \
- src/Makefile.in || die "sed failed"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ sed -i \
+ -e '/^\(gnu\)\?localedir /s:= .*:= /usr/share/locale:' \
+ po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^INCLUDES/s:\$(datadir)/locale:/usr/share/locale:' \
+ src/Makefile.in \
+ || die "sed failed"
}
-src_compile() {
- egamesconf $(use_enable nls) || die
- emake || die "emake failed"
+src_configure() {
+ egamesconf $(use_enable nls)
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
newicon data/ima/icono.png ${PN}.png
make_desktop_entry ceferino "Don Ceferino Hazaña"
diff --git a/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch b/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch
new file mode 100644
index 000000000000..96944dd382bb
--- /dev/null
+++ b/games-arcade/ceferino/files/ceferino-0.97.8-gcc44.patch
@@ -0,0 +1,11 @@
+--- src/nivel.h
++++ src/nivel.h
+@@ -34,7 +34,7 @@
+ class nivel
+ {
+ public:
+- void iniciar(juego *_pjuego, grafico *grafico, grafico *pfondos, SDL_Surface *fondo);
++ void iniciar(juego *_pjuego, grafico *_grafico, grafico *pfondos, SDL_Surface *fondo);
+ int avanzar_nivel(int salto = 1);
+ int reiniciar_nivel(void);
+ int get_dist_suelo(int x, int y, int max);