summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-16 16:16:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-16 16:16:04 +0000
commit62b65d4e11decf0495e48134903850ec7704dfa8 (patch)
treeb275795b9e85a47224037273ba222aab4cbd638c /games-arcade/crack-attack
parentBump. (Manifest recommit) (diff)
downloadgentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.tar.gz
gentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.tar.bz2
gentoo-2-62b65d4e11decf0495e48134903850ec7704dfa8.zip
ppc support
Diffstat (limited to 'games-arcade/crack-attack')
-rw-r--r--games-arcade/crack-attack/crack-attack-1.1.10.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-arcade/crack-attack/crack-attack-1.1.10.ebuild b/games-arcade/crack-attack/crack-attack-1.1.10.ebuild
index cd3309848cb3..f89fb4b0f9d1 100644
--- a/games-arcade/crack-attack/crack-attack-1.1.10.ebuild
+++ b/games-arcade/crack-attack/crack-attack-1.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/crack-attack/crack-attack-1.1.10.ebuild,v 1.4 2004/02/09 08:04:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/crack-attack/crack-attack-1.1.10.ebuild,v 1.5 2004/03/16 16:16:04 vapier Exp $
inherit games flag-o-matic gcc
@@ -10,7 +10,7 @@ SRC_URI="http://aluminumangel.org/cgi-bin/download_counter.cgi?attack_linux+atta
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 hppa"
+KEYWORDS="x86 ppc hppa"
IUSE=""
RDEPEND="media-libs/glut"
@@ -22,19 +22,19 @@ src_unpack() {
cd ${S}
sed -i \
-e 's:-O6:@CXXFLAGS@:' src/Makefile.in \
- || die "sed src/Makefile.in failed"
+ || die "sed src/Makefile.in failed"
}
src_compile() {
append-flags -DGL_GLEXT_LEGACY
[ "`gcc-fullversion`" == "3.2.3" ] && filter-flags -march=pentium3
egamesconf || die
- emake || die "emake failed"
+ emake || die "emake failed"
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog README || die "dodoc failed"
- dohtml -A xpm doc/* || die "dohtml failed"
+ dodoc AUTHORS ChangeLog README
+ dohtml -A xpm doc/*
prepgamesdirs
}