summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 22:50:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 22:50:01 +0000
commit46ea8ec96f3302afc633b332274bfc4c80e17d26 (patch)
treeb1ba7d0568ea5002d09bd7655a5e8eba45fd91be /games-arcade/penguin-command
parentStable on x86 (diff)
downloadgentoo-2-46ea8ec96f3302afc633b332274bfc4c80e17d26.tar.gz
gentoo-2-46ea8ec96f3302afc633b332274bfc4c80e17d26.tar.bz2
gentoo-2-46ea8ec96f3302afc633b332274bfc4c80e17d26.zip
Add back in sound support since changelog says they fixed some things.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'games-arcade/penguin-command')
-rw-r--r--games-arcade/penguin-command/ChangeLog10
-rw-r--r--games-arcade/penguin-command/files/digest-penguin-command-1.6.91
-rw-r--r--games-arcade/penguin-command/penguin-command-1.6.9.ebuild39
3 files changed, 48 insertions, 2 deletions
diff --git a/games-arcade/penguin-command/ChangeLog b/games-arcade/penguin-command/ChangeLog
index 8e79bcc180ad..763f37a0a292 100644
--- a/games-arcade/penguin-command/ChangeLog
+++ b/games-arcade/penguin-command/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/penguin-command
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/ChangeLog,v 1.10 2004/12/28 22:58:18 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/ChangeLog,v 1.11 2005/04/29 22:50:01 vapier Exp $
+
+*penguin-command-1.6.9 (29 Apr 2005)
+
+ 29 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +penguin-command-1.6.9.ebuild:
+ Add back in sound support since changelog says they fixed some things.
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-arcade/penguin-command/files/digest-penguin-command-1.6.9 b/games-arcade/penguin-command/files/digest-penguin-command-1.6.9
new file mode 100644
index 000000000000..1227824c20e0
--- /dev/null
+++ b/games-arcade/penguin-command/files/digest-penguin-command-1.6.9
@@ -0,0 +1 @@
+MD5 2280971eb5cf3a1e26446e30d3f04ecb penguin-command-1.6.9.tar.gz 1182053
diff --git a/games-arcade/penguin-command/penguin-command-1.6.9.ebuild b/games-arcade/penguin-command/penguin-command-1.6.9.ebuild
new file mode 100644
index 000000000000..20438163540c
--- /dev/null
+++ b/games-arcade/penguin-command/penguin-command-1.6.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/penguin-command-1.6.9.ebuild,v 1.1 2005/04/29 22:50:01 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A clone of the classic Missile Command Game"
+HOMEPAGE="http://www.linux-games.com/penguin-command/"
+SRC_URI="mirror://sourceforge/penguin-command/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="nls"
+
+DEPEND="media-libs/libpng
+ media-libs/jpeg
+ >=media-libs/libsdl-1.1.5
+ media-libs/sdl-mixer"
+
+#src_unpack() {
+# unpack ${A}
+# cd "${S}"
+# sed -i 's:-DUSE_SOUND::' configure
+#}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog README NEWS AUTHORS
+ if use nls ; then
+ dodir /usr/share/man/ja/man6
+ mv "${D}"/usr/share/man/man6/penguin-command.ja.6 "${D}"/usr/share/man/ja/man6/penguin-command.6
+ else
+ rm -f "${D}"/usr/share/man/man6/*.ja.*
+ fi
+ newicon data/gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN} ${PN}.xpm
+ prepgamesdirs
+}