summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-06 16:41:53 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-06 16:41:53 +0000
commit8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7 (patch)
tree760188d48002d50c5a5dc10ce9107b464676a647 /games-arcade/retrobattle/files
parentVersion bump. Update udev firmware search path and add /lib support patch. (diff)
downloadgentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.tar.gz
gentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.tar.bz2
gentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.zip
initial commit based on ebuild from Alexander Berntsen
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/retrobattle/files')
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch30
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch17
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
new file mode 100644
index 000000000000..3673ef01e17f
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
@@ -0,0 +1,30 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Aug 4 12:15:53 2012 +0200
+
+ respect CXX, CFLAGS and LDFLAGS
+
+--- src/Makefile
++++ src/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS = `sdl-config --cflags` -g -Wall -I. -DENABLE_BINRELOC
+-CPPFLAGS = $(CFLAGS)
++CXXFLAGS += $(shell sdl-config --cflags) -I.
++CPPFLAGS += -DENABLE_BINRELOC
+
+ # Uncomment the first LIBS line and comment out the other LIBS line to
+ # compile without SDL_Mixer
+ #LIBS = `sdl-config --libs`
+-LIBS = `sdl-config --libs` -lSDL_mixer
++LIBS = $(shell sdl-config --libs) -lSDL_mixer
+
+ RETROINSTALLDIR ?= /opt
+
+@@ -25,7 +25,7 @@
+
+
+ retrobattle: $(RETRO)
+- g++ -o $@ $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+ mv $@ ..
+
+ clean:
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
new file mode 100644
index 000000000000..591ce66e9f69
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-sound.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Aug 5 16:22:22 UTC 2012
+Subject: sound
+
+resolves crackling background music
+
+--- src/SoundManager.cc
++++ src/SoundManager.cc
+@@ -25,7 +25,7 @@
+ SoundManager::SoundManager(char *datadir)
+ {
+ #ifndef NO_SDL_MIXER
+- if(Mix_OpenAudio(22050, AUDIO_S16SYS, 2, 1024))
++ if(Mix_OpenAudio(44100, AUDIO_S16SYS, 2, 1024))
+ {
+ printf("SDL_mixer says: %s\n", Mix_GetError());
+ }