summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-14 00:30:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-14 00:30:36 +0000
commit383d68ba165413459fd28a30b1ba04795bbbc3f7 (patch)
tree6e6b7f2dc5c9fbf89934fb6d37d87002e4eb8585 /games-arcade
parentMoved Slot to 3.5 (diff)
downloadgentoo-2-383d68ba165413459fd28a30b1ba04795bbbc3f7.tar.gz
gentoo-2-383d68ba165413459fd28a30b1ba04795bbbc3f7.tar.bz2
gentoo-2-383d68ba165413459fd28a30b1ba04795bbbc3f7.zip
Fix building with glibc-2.10, bug #273508
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/kobodeluxe/ChangeLog8
-rw-r--r--games-arcade/kobodeluxe/files/kobodeluxe-0.5.1-glibc2.10.patch11
-rw-r--r--games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild13
3 files changed, 27 insertions, 5 deletions
diff --git a/games-arcade/kobodeluxe/ChangeLog b/games-arcade/kobodeluxe/ChangeLog
index 9dc4f17abd3c..69b6b0ecdeed 100644
--- a/games-arcade/kobodeluxe/ChangeLog
+++ b/games-arcade/kobodeluxe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/kobodeluxe
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/ChangeLog,v 1.29 2009/01/20 15:49:13 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/ChangeLog,v 1.30 2009/06/14 00:30:35 nyhm Exp $
+
+ 14 Jun 2009; Tristan Heaven <nyhm@gentoo.org> kobodeluxe-0.5.1.ebuild,
+ +files/kobodeluxe-0.5.1-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273508
20 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
kobodeluxe-0.5.1.ebuild:
diff --git a/games-arcade/kobodeluxe/files/kobodeluxe-0.5.1-glibc2.10.patch b/games-arcade/kobodeluxe/files/kobodeluxe-0.5.1-glibc2.10.patch
new file mode 100644
index 000000000000..1095cc1c7330
--- /dev/null
+++ b/games-arcade/kobodeluxe/files/kobodeluxe-0.5.1-glibc2.10.patch
@@ -0,0 +1,11 @@
+--- graphics/window.cpp
++++ graphics/window.cpp
+@@ -398,7 +398,7 @@
+ */
+ if(token)
+ {
+- char *tok = strchr(txt, token);
++ const char *tok = strchr(txt, token);
+ if(tok)
+ tokpos = tok-txt;
+ else
diff --git a/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild b/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild
index ddf7dd67991e..9a435502806e 100644
--- a/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild
+++ b/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild,v 1.7 2009/01/20 15:49:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild,v 1.8 2009/06/14 00:30:35 nyhm Exp $
EAPI=2
inherit eutils games
@@ -21,8 +21,16 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./icons.tar.gz
+}
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc29.patch
+ epatch \
+ "${FILESDIR}"/${P}-glibc29.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
# Fix paths
sed -i \
-e 's:\$(datadir)/kobo-deluxe:$(datadir)/kobodeluxe:' \
@@ -32,7 +40,6 @@ src_prepare() {
-e 's:kobo-deluxe:kobodeluxe:' \
data/gfx/Makefile.in \
data/sfx/Makefile.in || die "sed data/Makefile.in failed"
- tar xzvf icons.tar.gz || die "unpacking icons failed"
}
src_configure() {