summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-06-26 18:51:54 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-06-26 18:51:54 +0000
commit9c4085cb8db71cd53d81573dbd35224f9c55f2e1 (patch)
tree194ebf408c432a8eac4cc8e8de68f6eecca302ad /games-arcade
parentVersion bump (diff)
downloadgentoo-2-9c4085cb8db71cd53d81573dbd35224f9c55f2e1.tar.gz
gentoo-2-9c4085cb8db71cd53d81573dbd35224f9c55f2e1.tar.bz2
gentoo-2-9c4085cb8db71cd53d81573dbd35224f9c55f2e1.zip
bumped EAPI to 5; converted deps to gx86-multilib, note that i had no access to the distfile so i can not confirm deps are truely correct
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/aquaria/ChangeLog9
-rw-r--r--games-arcade/aquaria/aquaria-1.1.3-r1.ebuild58
2 files changed, 66 insertions, 1 deletions
diff --git a/games-arcade/aquaria/ChangeLog b/games-arcade/aquaria/ChangeLog
index 9dcc03871d7a..002861cbd8e6 100644
--- a/games-arcade/aquaria/ChangeLog
+++ b/games-arcade/aquaria/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/aquaria
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/ChangeLog,v 1.6 2014/04/15 11:50:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/ChangeLog,v 1.7 2014/06/26 18:51:54 axs Exp $
+
+*aquaria-1.1.3-r1 (26 Jun 2014)
+
+ 26 Jun 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +aquaria-1.1.3-r1.ebuild:
+ bumped EAPI to 5; converted deps to gx86-multilib, note that i had no access
+ to the distfile so i can not confirm deps are truely correct
15 Apr 2014; Ulrich Müller <ulm@gentoo.org> aquaria-1.1.3.ebuild:
Fix LICENSE, add bindist restriction, bug 505618.
diff --git a/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild b/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..fc16a21584bc
--- /dev/null
+++ b/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/aquaria-1.1.3-r1.ebuild,v 1.1 2014/06/26 18:51:54 axs Exp $
+
+EAPI=5
+
+inherit unpacker eutils games
+
+DESCRIPTION="A 2D scroller set in a massive ocean world"
+HOMEPAGE="http://www.bit-blot.com/aquaria/"
+SRC_URI="aquaria-lnx-humble-bundle.mojo.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip fetch bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND="|| (
+ (
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ )
+ amd64? ( app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)] )
+)"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ echo
+ elog "Download ${SRC_URI} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ echo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ doins -r *.xml */
+ doexe "${PN}"
+ doicon "${PN}.png"
+
+ dodoc README-linux.txt
+ mv "${ED}/${dir}"/docs "${ED}/usr/share/doc/${PF}/html" || die
+ dosym /usr/share/doc/${PF}/html "${dir}"/docs
+
+ games_make_wrapper "${PN}" "./${PN}" "${dir}"
+ make_desktop_entry "${PN}" "Aquaria"
+
+ prepgamesdirs
+}