summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-24 13:12:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-24 13:12:18 +0000
commitd540f1b2f14d51521365fcff348982643436cc67 (patch)
treebfae8853fc18e4e718264720e62104d13ad98171 /games-arcade
parentuse games eclass (diff)
downloadgentoo-2-d540f1b2f14d51521365fcff348982643436cc67.tar.gz
gentoo-2-d540f1b2f14d51521365fcff348982643436cc67.tar.bz2
gentoo-2-d540f1b2f14d51521365fcff348982643436cc67.zip
use games eclass
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdlroids/ChangeLog8
-rw-r--r--games-arcade/sdlroids/Manifest4
-rw-r--r--games-arcade/sdlroids/files/digest-sdlroids-1.3.4-r31
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild33
4 files changed, 43 insertions, 3 deletions
diff --git a/games-arcade/sdlroids/ChangeLog b/games-arcade/sdlroids/ChangeLog
index affcf09a4ac3..37b0a0a7fffa 100644
--- a/games-arcade/sdlroids/ChangeLog
+++ b/games-arcade/sdlroids/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/sdlroids
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.3 2004/01/24 12:48:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.4 2004/01/24 13:12:12 mr_bones_ Exp $
+
+*sdlroids-1.3.4-r3 (24 Jan 2004)
+
+ 24 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ sdlroids-1.3.4-r3.ebuild:
+ use games eclass
24 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org>
sdlroids-1.3.4-r1.ebuild, sdlroids-1.3.4-r2.ebuild:
diff --git a/games-arcade/sdlroids/Manifest b/games-arcade/sdlroids/Manifest
index 4d8008c28134..20f76a61cd5b 100644
--- a/games-arcade/sdlroids/Manifest
+++ b/games-arcade/sdlroids/Manifest
@@ -1,5 +1,5 @@
-MD5 b1a1fe1f282da8bba3396ac1326c2cdd ChangeLog 1394
-MD5 999d971547ba9c0f99aff5406636e634 sdlroids-1.3.4-r3.ebuild 656
+MD5 989b741cac286c4c7e6e35163f346df9 ChangeLog 1531
+MD5 355efbb6932f7c680ae8caa588623cc8 sdlroids-1.3.4-r3.ebuild 864
MD5 28b895cd458d27f11501e66f9e0d6824 sdlroids-1.3.4-r2.ebuild 835
MD5 b244cf1c41a78cacb62296d573935c07 metadata.xml 245
MD5 933513560ad26be0b6fc1e21bb526a64 files/digest-sdlroids-1.3.4-r3 67
diff --git a/games-arcade/sdlroids/files/digest-sdlroids-1.3.4-r3 b/games-arcade/sdlroids/files/digest-sdlroids-1.3.4-r3
new file mode 100644
index 000000000000..185a47f0da83
--- /dev/null
+++ b/games-arcade/sdlroids/files/digest-sdlroids-1.3.4-r3
@@ -0,0 +1 @@
+MD5 ae3c310bf2871809a0e8317f47bf0b50 sdlroids-1.3.4.tar.bz2 136588
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
new file mode 100644
index 000000000000..3468d25e3a47
--- /dev/null
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.1 2004/01/24 13:12:12 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Asteroids Clone for X using SDL"
+HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
+SRC_URI="mirror://sourceforge/sdlroids/${P}.tar.bz2"
+
+RESTRICT="nomirror"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.8
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' ${S}/Makefile.in \
+ || die "sed Makefile.in failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README.* TODO || die "dodoc failed"
+ prepgamesdirs
+}