summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-03 17:58:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-03 17:58:15 +0000
commit8f7737e3a61ec323f67c02b6a253fb33ebb2793a (patch)
tree6a6a40b8c104bdc556457e7ab7fe2de745a64174 /games-emulation/atari800
parent* sync with cvs (diff)
downloadgentoo-2-8f7737e3a61ec323f67c02b6a253fb33ebb2793a.tar.gz
gentoo-2-8f7737e3a61ec323f67c02b6a253fb33ebb2793a.tar.bz2
gentoo-2-8f7737e3a61ec323f67c02b6a253fb33ebb2793a.zip
version bump (bug #101221)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/atari800')
-rw-r--r--games-emulation/atari800/ChangeLog8
-rw-r--r--games-emulation/atari800/Manifest18
-rw-r--r--games-emulation/atari800/atari800-1.3.6.ebuild91
-rw-r--r--games-emulation/atari800/files/digest-atari800-1.3.62
4 files changed, 105 insertions, 14 deletions
diff --git a/games-emulation/atari800/ChangeLog b/games-emulation/atari800/ChangeLog
index 76c1e5aac286..cd6e7db67094 100644
--- a/games-emulation/atari800/ChangeLog
+++ b/games-emulation/atari800/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/atari800
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/ChangeLog,v 1.10 2005/03/29 01:04:48 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/ChangeLog,v 1.11 2005/08/03 17:58:15 mr_bones_ Exp $
+
+*atari800-1.3.6 (03 Aug 2005)
+
+ 03 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +atari800-1.3.6.ebuild:
+ version bump (bug #101221)
29 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> atari800-1.3.5.ebuild:
added ~amd64 to KEYWORDS, fixes #74444
diff --git a/games-emulation/atari800/Manifest b/games-emulation/atari800/Manifest
index 4668e85b013b..321e57ecfac3 100644
--- a/games-emulation/atari800/Manifest
+++ b/games-emulation/atari800/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 3e34f92f94ef04fe78f7c0204f62bd92 atari800-1.3.5.ebuild 2380
+MD5 d1fb8b39c231a1671ed7c95f426130e6 metadata.xml 866
+MD5 3e34f92f94ef04fe78f7c0204f62bd92 atari800-1.3.6.ebuild 2380
MD5 92c840bdbd328b174f5b42f92bce0eee atari800-1.3.4.ebuild 2373
MD5 06a5f68d73c6f413b43153d51d8fe695 ChangeLog 2553
-MD5 d1fb8b39c231a1671ed7c95f426130e6 metadata.xml 866
+MD5 3e34f92f94ef04fe78f7c0204f62bd92 atari800-1.3.5.ebuild 2380
+MD5 c985421e05510bde42a8ed91774884b6 files/atari800.cfg 467
MD5 5dbf9ebfa0b38c8d39e1b1a6fa9fce38 files/digest-atari800-1.3.4 120
+MD5 baa68b7966877ad81b9be6c65fbfbcdf files/digest-atari800-1.3.6 120
MD5 849d0429b9151cfeeba97049ab911bed files/digest-atari800-1.3.5 120
-MD5 c985421e05510bde42a8ed91774884b6 files/atari800.cfg 467
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCSKm506ebR+OMO78RArcmAJ9DkrF3dDowg+PK7vabgf7e0z5qsgCgmUY3
-8JVT65mvsQkJR0cIKYBAiDQ=
-=AIrc
------END PGP SIGNATURE-----
diff --git a/games-emulation/atari800/atari800-1.3.6.ebuild b/games-emulation/atari800/atari800-1.3.6.ebuild
new file mode 100644
index 000000000000..c1e86159374c
--- /dev/null
+++ b/games-emulation/atari800/atari800-1.3.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/atari800/atari800-1.3.6.ebuild,v 1.1 2005/08/03 17:58:15 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari 800 emulator"
+HOMEPAGE="http://atari800.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atari800/${P}.tar.gz
+ mirror://sourceforge/atari800/xf25.zip"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha ~amd64"
+IUSE="sdl"
+
+RDEPEND="virtual/x11
+ sdl? ( >=media-libs/libsdl-1.2.0 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # remove some not-so-interesting ones
+ rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD}
+}
+
+src_compile() {
+ local target="x11"
+ use sdl && target="sdl"
+
+ cd src && \
+ egamesconf \
+ --enable-crashmenu \
+ --enable-break \
+ --enable-hints \
+ --enable-asm \
+ --enable-cursorblk \
+ --enable-led \
+ --enable-displayled \
+ --enable-sndclip \
+ --enable-linuxjoy \
+ --enable-sound \
+ --target=${target} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install () {
+ dogamesbin src/atari800 || die "dogamesbin failed"
+ newman src/atari800.man atari800.6
+ dodoc README.1ST DOC/*
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins "${WORKDIR}/"*.ROM || die "doins failed (ROM)"
+ insinto /etc
+ doins "${FILESDIR}/atari800.cfg" || die "doins failed (cfg)"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use sdl ; then
+ echo
+ echo
+ einfo 'The emulator has been compiled using the SDL libraries. By default,'
+ einfo 'atari800 switches to fullscreen mode, so a 400x300 entry in your'
+ einfo 'XF86Config-4 file is recommended. Otherwise, the emulated Atari'
+ einfo 'screen is postage-stamp sized in the middle of your display.'
+ echo
+ einfo 'For example, in the "Screen" section of your /etc/XF86Config-4 file,'
+ einfo 'add the entry "400x300" to the end of the list of modes:'
+ echo
+ einfo ' Section "Screen"'
+ einfo ' [...]'
+ einfo
+ einfo ' Subsection "Display"'
+ einfo ' Depth 16'
+ einfo ' Modes "1600x1200" "1024x768" "400x300"'
+ einfo ' ViewPort 0 0'
+ einfo ' EndSubsection'
+ einfo ' EndSection'
+ echo
+ einfo 'You should not need to specify a modeline for this mode,'
+ einfo 'since in most cases it is a standard mode calculated by'
+ einfo 'the X server.'
+ echo
+ echo
+ echo
+ fi
+}
diff --git a/games-emulation/atari800/files/digest-atari800-1.3.6 b/games-emulation/atari800/files/digest-atari800-1.3.6
new file mode 100644
index 000000000000..9a6e80a05806
--- /dev/null
+++ b/games-emulation/atari800/files/digest-atari800-1.3.6
@@ -0,0 +1,2 @@
+MD5 98b58d26aabeedb124233787677c32c3 atari800-1.3.6.tar.gz 1012231
+MD5 4dc3b6b4313e9596c4d474785a37b94d xf25.zip 188942