summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-28 00:13:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-28 00:13:14 +0000
commita0a6f11939b3bb66085ff79e472f3f2ce4b2afd0 (patch)
tree6f7242434a9fe960dfe8696f58e460d1958cd723 /games-emulation/daphne
parentRemoved kunststoff-bin (bug #159243) as there is a from sources version dev-j... (diff)
downloadgentoo-2-a0a6f11939b3bb66085ff79e472f3f2ce4b2afd0.tar.gz
gentoo-2-a0a6f11939b3bb66085ff79e472f3f2ce4b2afd0.tar.bz2
gentoo-2-a0a6f11939b3bb66085ff79e472f3f2ce4b2afd0.zip
Version bump, bug #119982
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'games-emulation/daphne')
-rw-r--r--games-emulation/daphne/ChangeLog9
-rw-r--r--games-emulation/daphne/daphne-0.99.7.ebuild68
-rw-r--r--games-emulation/daphne/files/daphne-0.99.7-exec-stack.patch18
-rw-r--r--games-emulation/daphne/files/daphne-0.99.7-gcc41.patch22
-rw-r--r--games-emulation/daphne/files/digest-daphne-0.99.73
5 files changed, 119 insertions, 1 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index 1ea0c4d6d4ba..ba28214527cf 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/daphne
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.10 2006/08/28 01:53:27 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.11 2006/12/28 00:13:14 nyhm Exp $
+
+*daphne-0.99.7 (28 Dec 2006)
+
+ 28 Dec 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/daphne-0.99.7-exec-stack.patch, +files/daphne-0.99.7-gcc41.patch,
+ +daphne-0.99.7.ebuild:
+ Version bump, bug #119982
28 Aug 2006; <tupone@gentoo.org> +files/daphne-0.99.6-gcc41.patch,
daphne-0.99.6-r2.ebuild:
diff --git a/games-emulation/daphne/daphne-0.99.7.ebuild b/games-emulation/daphne/daphne-0.99.7.ebuild
new file mode 100644
index 000000000000..ce11fa4a8e04
--- /dev/null
+++ b/games-emulation/daphne/daphne-0.99.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.7.ebuild,v 1.1 2006/12/28 00:13:14 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Laserdisc Arcade Game Emulator"
+HOMEPAGE="http://www.daphne-emu.com/"
+SRC_URI="http://www.daphne-emu.com/download/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libogg
+ media-libs/libvorbis
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ sed -i "/m_appdir =/s:\.:${GAMES_DATADIR}/${PN}:" \
+ io/homedir.cpp \
+ || die "sed homedir.cpp failed"
+ sed -i "s:pics/:${GAMES_DATADIR}/${PN}/&:" \
+ video/video.cpp \
+ || die "sed video.cpp failed"
+ sed -i "s:sound/:${GAMES_DATADIR}/${PN}/&:" \
+ sound/sound.cpp \
+ || die "sed sound.cpp failed"
+ sed -i "s:./lib:${GAMES_LIBDIR}/${PN}/lib:" \
+ io/dll.h \
+ || die "sed dll.h failed"
+ cp Makefile.vars{.linux_x86,}
+}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ DFLAGS="${CXXFLAGS}" \
+ || die "src build failed"
+ cd vldp2
+ egamesconf || die
+ emake \
+ -f Makefile.linux \
+ CC=$(tc-getCC) \
+ DFLAGS="${CFLAGS}" \
+ || die "vldp2 build failed"
+}
+
+src_install() {
+ cd ..
+ dogamesbin daphne || die "dogamesbin failed"
+ exeinto "${GAMES_LIBDIR}"/${PN}
+ doexe libvldp2.so || die "doexe failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r pics roms sound || die "doins failed"
+ dodoc doc/*.{ini,txt}
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/games-emulation/daphne/files/daphne-0.99.7-exec-stack.patch b/games-emulation/daphne/files/daphne-0.99.7-exec-stack.patch
new file mode 100644
index 000000000000..67de83272ac5
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-0.99.7-exec-stack.patch
@@ -0,0 +1,18 @@
+--- video/blend_mmx-gas.s
++++ video/blend_mmx-gas.s
+@@ -93,3 +93,6 @@
+ ret
+
+ ####################################################
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- video/rgb2yuv-gas.s
++++ video/rgb2yuv-gas.s
+@@ -149,3 +149,6 @@
+ popl %ebp
+
+ ret
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-emulation/daphne/files/daphne-0.99.7-gcc41.patch b/games-emulation/daphne/files/daphne-0.99.7-gcc41.patch
new file mode 100644
index 000000000000..83766ed10fad
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-0.99.7-gcc41.patch
@@ -0,0 +1,22 @@
+--- game/lgp.h
++++ game/lgp.h
+@@ -59,7 +59,7 @@
+ bool nmie;
+ Uint8 banks[7];
+ void recalc_palette();
+- void lgp::draw_8x8(int character_number, int xcoord, int ycoord);
++ void draw_8x8(int character_number, int xcoord, int ycoord);
+ };
+
+ #endif
+--- ldp-out/pioneer.h
++++ ldp-out/pioneer.h
+@@ -47,7 +47,7 @@
+ bool pioneer_audio1;
+ bool pioneer_audio2;
+ bool check_result(Uint32, bool);
+- bool pioneer::getstring(char *, int, Uint32,bool);
++ bool getstring(char *, int, Uint32,bool);
+ void printmodel();
+ };
+
diff --git a/games-emulation/daphne/files/digest-daphne-0.99.7 b/games-emulation/daphne/files/digest-daphne-0.99.7
new file mode 100644
index 000000000000..2adb845a5b1c
--- /dev/null
+++ b/games-emulation/daphne/files/digest-daphne-0.99.7
@@ -0,0 +1,3 @@
+MD5 887802217036a0bc1827ef2d2b8d17a8 daphne-0.99.7-src.tar.gz 3499980
+RMD160 0607bf6a275f3ada240d8ee4b5ffca44e7ceb246 daphne-0.99.7-src.tar.gz 3499980
+SHA256 6b40f2028cac01803318bc2d62ad3a3c7d98b3d49d846312e30d2b52fadfce51 daphne-0.99.7-src.tar.gz 3499980