summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-25 03:40:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-25 03:40:45 +0000
commit4001762d22f874990831b380476874f5a942995f (patch)
treeebd8b43101269513e98826c97e91af9e7d9b10d5 /games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
parentChanged einfo calls to echo. (diff)
downloadgentoo-2-4001762d22f874990831b380476874f5a942995f.tar.gz
gentoo-2-4001762d22f874990831b380476874f5a942995f.tar.bz2
gentoo-2-4001762d22f874990831b380476874f5a942995f.zip
patch for gcc-3.4 (bug #116113)
(Portage version: 2.0.53)
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
index ba15a97893f0..eb1b402cec55 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.8 2005/01/09 10:50:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.9 2005/12/25 03:40:45 mr_bones_ Exp $
-inherit games gnuconfig
+inherit eutils gnuconfig games
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://www.pknet.com/~joe/dgen-sdl.html"
SRC_URI="http://www.pknet.com/~joe/${P}.tar.gz"
LICENSE="dgen-sdl"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE="X mmx opengl"
RDEPEND="media-libs/libsdl
@@ -19,6 +19,12 @@ RDEPEND="media-libs/libsdl
DEPEND="${DEPEND}
dev-lang/nasm"
+src_unpack() {
+ unpack ${A}
+ cd "${S}/star"
+ epatch "${FILESDIR}/${P}-gcc34.patch" # for bug #116113
+}
+
src_compile() {
gnuconfig_update