summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-28 08:14:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-28 08:14:45 +0000
commit5c30a46d0e88894c31db6325dd6dce8f63a51a14 (patch)
treedded1393f09cd9f1569fb83c2bf260c6da631302 /games-emulation/gens
parentVersion bump and remove old. Update DESCRIPTION, remove old wxwidgets support... (diff)
downloadgentoo-2-5c30a46d0e88894c31db6325dd6dce8f63a51a14.tar.gz
gentoo-2-5c30a46d0e88894c31db6325dd6dce8f63a51a14.tar.bz2
gentoo-2-5c30a46d0e88894c31db6325dd6dce8f63a51a14.zip
Fix overflow. Bug #340665
(Portage version: 2.1.9.22/cvs/Linux i686)
Diffstat (limited to 'games-emulation/gens')
-rw-r--r--games-emulation/gens/ChangeLog8
-rw-r--r--games-emulation/gens/files/gens-2.15.5-ovflfix.patch13
-rw-r--r--games-emulation/gens/gens-2.15.5.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/games-emulation/gens/ChangeLog b/games-emulation/gens/ChangeLog
index fb0548565a8b..3fc7e1fbe7d6 100644
--- a/games-emulation/gens/ChangeLog
+++ b/games-emulation/gens/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gens
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.20 2009/11/20 14:21:52 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.21 2010/10/28 08:14:45 tupone Exp $
+
+ 28 Oct 2010; Tupone Alfredo <tupone@gentoo.org> gens-2.15.5.ebuild,
+ +files/gens-2.15.5-ovflfix.patch:
+ Fix overflow. Bug #340665 by flameeyes@gentoo.org
20 Nov 2009; Markus Meier <maekke@gentoo.org> gens-2.15.5.ebuild:
x86 stable, bug #286310
diff --git a/games-emulation/gens/files/gens-2.15.5-ovflfix.patch b/games-emulation/gens/files/gens-2.15.5-ovflfix.patch
new file mode 100644
index 000000000000..f5b98a54245f
--- /dev/null
+++ b/games-emulation/gens/files/gens-2.15.5-ovflfix.patch
@@ -0,0 +1,13 @@
+--- src/gens/gens_core/cpu/68k/cpu_68k.c.old 2010-10-28 09:34:52.000000000 +0200
++++ src/gens/gens_core/cpu/68k/cpu_68k.c 2010-10-28 09:35:53.000000000 +0200
+@@ -239,8 +239,8 @@
+ memset (Ram_Word_2M, 0, 256 * 1024);
+ memset (Ram_Word_1M, 0, 256 * 1024);
+
+- memset (COMM.Command, 0, 8 * 5);
+- memset (COMM.Status, 0, 8 * 5);
++ memset (COMM.Command, 0, sizeof (COMM.Command));
++ memset (COMM.Status, 0, sizeof (COMM.Status));
+
+ LED_Status = S68K_State = S68K_Mem_WP = S68K_Mem_PM = Ram_Word_State = 0;
+ COMM.Flag = Init_Timer_INT3 = Timer_INT3 = Int_Mask_S68K = 0;
diff --git a/games-emulation/gens/gens-2.15.5.ebuild b/games-emulation/gens/gens-2.15.5.ebuild
index 4a97e70f7d04..afc7682bd12c 100644
--- a/games-emulation/gens/gens-2.15.5.ebuild
+++ b/games-emulation/gens/gens-2.15.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.5.ebuild,v 1.5 2009/11/23 01:10:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.5.ebuild,v 1.6 2010/10/28 08:14:45 tupone Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -22,7 +22,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-romsdir.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
append-ldflags -Wl,-z,noexecstack
}