summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/psemu-cdriso
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/psemu-cdriso')
-rw-r--r--games-emulation/psemu-cdriso/ChangeLog25
-rw-r--r--games-emulation/psemu-cdriso/Manifest4
-rw-r--r--games-emulation/psemu-cdriso/files/1.4-makefile-cflags.patch11
-rw-r--r--games-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.41
-rw-r--r--games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild41
5 files changed, 82 insertions, 0 deletions
diff --git a/games-emulation/psemu-cdriso/ChangeLog b/games-emulation/psemu-cdriso/ChangeLog
new file mode 100644
index 000000000000..9149d94347d5
--- /dev/null
+++ b/games-emulation/psemu-cdriso/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-emulation/psemu-cdriso
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*psemu-cdriso-1.4 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + games.eclass support.
+
+*psemu-cdriso-1.2 (27 Jul 2002)
+
+ 06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
+ Added -ppc to keywords
+
+ 27 Jul 2002; Stuart Bouyer <stubear@gentoo.org> psemu-cdriso-1.2.ebuild :
+ Added KEYWORDS="x86", RDEPEND and SLOT for lintool and repoman happiness.
+
+*psemu-cdriso-1.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-emulation/psemu-cdriso/Manifest b/games-emulation/psemu-cdriso/Manifest
new file mode 100644
index 000000000000..8f4cfd5741a7
--- /dev/null
+++ b/games-emulation/psemu-cdriso/Manifest
@@ -0,0 +1,4 @@
+MD5 8bf7b590c0c6f744b566d2a335078b39 files/digest-psemu-cdriso-1.4 59
+MD5 ce620a6a8f6cf5455642414b35bb3c86 files/1.4-makefile-cflags.patch 454
+MD5 9b342ccbd8c234f56cb0b65dd8f2b253 psemu-cdriso-1.4.ebuild 869
+MD5 e2e48fa1fa9413582e6f93220d54aa81 ChangeLog 1091
diff --git a/games-emulation/psemu-cdriso/files/1.4-makefile-cflags.patch b/games-emulation/psemu-cdriso/files/1.4-makefile-cflags.patch
new file mode 100644
index 000000000000..bcac309b94aa
--- /dev/null
+++ b/games-emulation/psemu-cdriso/files/1.4-makefile-cflags.patch
@@ -0,0 +1,11 @@
+--- cdriso/src/Linux/Makefile.orig 2003-08-14 01:26:32.970330336 -0400
++++ cdriso/src/Linux/Makefile 2003-08-14 01:26:44.489579144 -0400
+@@ -6,7 +6,7 @@
+ BUILD = 4
+ PLUGIN = libcdriso-${VERSION}.${BUILD}.so
+ CFG = cfgCdrIso
+-CFLAGS = -fPIC -Wall -O2 -fomit-frame-pointer -I.. -I. -D__LINUX__
++CFLAGS = -fPIC -Wall $(OPTFLAGS) -I.. -I. -D__LINUX__
+ OBJECTS = ../cdriso.o Config.o Linux.o
+ CFGOBJS = conf.o interface.o support.o Config.o
+ LIBS = -lz -lbz2
diff --git a/games-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.4 b/games-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.4
new file mode 100644
index 000000000000..47ee78cee1d6
--- /dev/null
+++ b/games-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.4
@@ -0,0 +1 @@
+MD5 7688a0e07527a5ce9ca974ffead3c13d cdriso-1.4.tgz 130168
diff --git a/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
new file mode 100644
index 000000000000..ab59dd42cf7e
--- /dev/null
+++ b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="PSEmu plugin to read CD-images"
+HOMEPAGE="http://www.pcsx.net/"
+SRC_URI="http://linuzappz.pcsx.net/downloads/cdriso-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/zlib
+ sys-apps/bzip2
+ =x11-libs/gtk+-1*
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/cdriso
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+}
+
+src_compile() {
+ cd src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd src/Linux
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe libcdriso-*
+ exeinto ${GAMES_LIBDIR}/psemu/cfg
+ doexe cfgCdrIso
+ prepgamesdirs
+}
+