summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/snes9x/files
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/digest-snes9x-1391
-rw-r--r--games-emulation/snes9x/files/digest-snes9x-139-r11
-rw-r--r--games-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff26
-rw-r--r--games-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff37
-rw-r--r--games-emulation/snes9x/files/snes9x-gcc3.diff35
5 files changed, 100 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/digest-snes9x-139 b/games-emulation/snes9x/files/digest-snes9x-139
new file mode 100644
index 000000000000..7436413f1239
--- /dev/null
+++ b/games-emulation/snes9x/files/digest-snes9x-139
@@ -0,0 +1 @@
+MD5 eb8fb2cc365a9dcc18106a05bcdd3ac1 s9xs139.zip 666463
diff --git a/games-emulation/snes9x/files/digest-snes9x-139-r1 b/games-emulation/snes9x/files/digest-snes9x-139-r1
new file mode 100644
index 000000000000..7436413f1239
--- /dev/null
+++ b/games-emulation/snes9x/files/digest-snes9x-139-r1
@@ -0,0 +1 @@
+MD5 eb8fb2cc365a9dcc18106a05bcdd3ac1 s9xs139.zip 666463
diff --git a/games-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff b/games-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff
new file mode 100644
index 000000000000..b24de16d41c1
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff
@@ -0,0 +1,26 @@
+--- release/unix/unix.cpp.orig 2003-03-02 03:33:54.000000000 +0100
++++ release/unix/unix.cpp 2003-03-02 03:35:10.000000000 +0100
+@@ -1463,7 +1463,11 @@
+ perror ("ioctl SNDCTL_DSP_SETTRIGGER");
+ #endif
+
++#ifdef MSB_FIRST
++ J = AFMT_S16_BE;
++#else
+ J = AFMT_S16_LE;
++#endif
+ // J = AFMT_U8;
+ if (ioctl (so.sound_fd, SNDCTL_DSP_SETFMT, &J) < 0)
+ {
+@@ -1471,7 +1475,11 @@
+ return (FALSE);
+ }
+
++#ifdef MSB_FIRST
++ if (J != AFMT_S16_BE)
++#else
+ if (J != AFMT_S16_LE)
++#endif
+ {
+ so.sixteen_bit = FALSE;
+ J = AFMT_U8;
diff --git a/games-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff b/games-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff
new file mode 100644
index 000000000000..09fee05cb903
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff
@@ -0,0 +1,37 @@
+--- release.orig/Makefile.linux 2003-02-11 05:27:20.000000000 +0000
++++ release/Makefile.linux 2003-02-11 05:28:24.000000000 +0000
+@@ -1,13 +1,13 @@
+-ZSNESFX=1
+-ZSNESC4=1
+-ASMCPU=1
++#ZSNESFX=1
++#ZSNESC4=1
++#ASMCPU=1
+ #SPC700ASM=1
+ NETPLAY=1
+ UNZIP=1
+ #GLIDE=1
+ #OPENGL=1
+ THREAD_SOUND=1
+-ASMKREED=1
++#ASMKREED=1
+
+ ifdef ZSNESFX
+ FXOBJ=i386/fxemu2b.o i386/fxemu2.o i386/fxemu2c.o i386/fxtable.o i386/sfxproc.o i386/zsnes.o
+@@ -39,7 +39,7 @@
+ SOUNDOBJ=spctool/spc700.o spctool/dsp.o spctool.o spctool/soundmod.o spc.o
+ SOUNDDEFINES=-DSPCTOOL
+ else
+-SOUNDOBJ=spc700.o soundux.o apu.o i386/spc.o
++SOUNDOBJ=spc700.o soundux.o apu.o
+ SOUNDDEFINES=-DSPC700_C
+ endif
+
+@@ -111,7 +111,6 @@
+ OPTIMISE=
+
+ CCFLAGS = $(OPTIMISE) -DMITSHM \
+--Ii386 \
+ -I. \
+ -Iunzip \
+ -DJOYSTICK_SUPPORT \
diff --git a/games-emulation/snes9x/files/snes9x-gcc3.diff b/games-emulation/snes9x/files/snes9x-gcc3.diff
new file mode 100644
index 000000000000..d65616446cff
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-gcc3.diff
@@ -0,0 +1,35 @@
+diff -ur release.orig/Makefile.linux release/Makefile.linux
+--- release.orig/Makefile.linux Sun Jul 14 18:24:34 2002
++++ release/Makefile.linux Sun Jul 14 18:24:48 2002
+@@ -102,7 +102,7 @@
+ OPENGLNO_DEPENDS=use_opengl
+ endif
+
+-CCC = gcc
++CCC = g++
+ CC = gcc
+ NASM = nasm
+
+diff -ur release.orig/unix/config.c release/unix/config.c
+--- release.orig/unix/config.c Sun Jul 14 18:24:34 2002
++++ release/unix/config.c Sun Jul 14 18:25:01 2002
+@@ -528,7 +528,7 @@
+ p = find_config_string(config[0], section, name, NULL);
+
+ if (p)
+- return (p->data ? p->data : "");
++ return (p->data ? p->data : (char*) "");
+ else
+ return def;
+ }
+--- release.orig/Makefile.linux 2002-10-03 16:04:29.000000000 -0400
++++ release/Makefile.linux 2001-09-18 02:04:07.000000000 -0400
+@@ -108,7 +108,7 @@
+
+ INCLUDES=-I/usr/X11R6/include -I/usr/local/include
+
+-OPTIMISE=-O6 -mpentium -fomit-frame-pointer -fno-exceptions
++OPTIMISE=
+
+ CCFLAGS = $(OPTIMISE) -DMITSHM \
+ -Ii386 \