summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-15 16:57:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-15 16:57:04 +0000
commite66be084d6299276b6fc80ea57ea1e602489f408 (patch)
tree3259ad96b6d4bb62b777539f21ff4dc8d4a8fab1 /games-emulation/snes9x
parentQA, removed WANT_AUTO*=latest (diff)
downloadgentoo-2-e66be084d6299276b6fc80ea57ea1e602489f408.tar.gz
gentoo-2-e66be084d6299276b6fc80ea57ea1e602489f408.tar.bz2
gentoo-2-e66be084d6299276b6fc80ea57ea1e602489f408.zip
Restore png screenshot feature (thanks to emul- 20100611 pkgs).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog8
-rw-r--r--games-emulation/snes9x/snes9x-1.52-r1.ebuild126
2 files changed, 133 insertions, 1 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 4ff93b918c5f..87922a468706 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/snes9x
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.41 2010/05/31 20:32:35 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.42 2010/06/15 16:57:04 ssuominen Exp $
+
+*snes9x-1.52-r1 (15 Jun 2010)
+
+ 15 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +snes9x-1.52-r1.ebuild:
+ Restore png screenshot feature (thanks to emul- 20100611 pkgs).
31 May 2010; Joseph Jezak <josejx@gentoo.org> snes9x-1.52.ebuild:
Marked ~ppc for bug #314197.
diff --git a/games-emulation/snes9x/snes9x-1.52-r1.ebuild b/games-emulation/snes9x/snes9x-1.52-r1.ebuild
new file mode 100644
index 000000000000..47fe2ec6e0db
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.52-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.52-r1.ebuild,v 1.1 2010/06/15 16:57:04 ssuominen Exp $
+
+EAPI=3
+inherit autotools eutils flag-o-matic multilib gnome2-utils games
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="http://code.google.com/p/snes9x-gtk/"
+SRC_URI="http://snes9x-gtk.googlecode.com/files/${P}-src.tar.bz2"
+
+LICENSE="as-is GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="alsa debug gtk joystick multilib netplay nls opengl oss png pulseaudio portaudio +xv +xrandr zlib"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ png? ( >=media-libs/libpng-1.2.43 )
+ amd64? ( png? ( >=media-libs/libpng-1.4.2 )
+ multilib? ( >=app-emulation/emul-linux-x86-xlibs-20100611
+ gtk? ( >=app-emulation/emul-linux-x86-gtklibs-20100611
+ joystick? ( >=app-emulation/emul-linux-x86-sdl-20100611 ) )
+ ) )
+ gtk? ( >=x11-libs/gtk+-2.10:2
+ >=gnome-base/libglade-2.0
+ x11-misc/xdg-utils
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ joystick? ( >=media-libs/libsdl-1.2.12[joystick] )
+ opengl? ( virtual/opengl )
+ xv? ( x11-libs/libXv )
+ xrandr? ( x11-libs/libXrandr )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio ) )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ x11-proto/xproto
+ gtk? ( dev-util/pkgconfig
+ xv? ( x11-proto/videoproto ) )
+ nls? ( dev-util/intltool )"
+
+S=${WORKDIR}/${P}-src/unix
+
+pkg_setup() {
+ use amd64 && use multilib && [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] && \
+ has_multilib_profile && ABI=x86
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+ if use gtk; then
+ cd ../gtk
+ sed -i -e '/PKG_CHECK_MODULES(\[LIBPNG/d' configure.ac || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+
+ egamesconf \
+ $(use_enable x86 zsnes-asm) \
+ $(use_enable joystick gamepad) \
+ $(use_enable debug debugger) \
+ $(use_enable netplay) \
+ $(use_enable zlib gzip) \
+ $(use_enable zlib zip) \
+ $(use_enable png screenshot)
+
+ if use gtk; then
+ cd ../gtk
+ egamesconf \
+ --datadir="${EPREFIX}/usr/share" \
+ $(use_enable nls) \
+ $(use_with opengl) \
+ $(use_with joystick) \
+ $(use_with xv) \
+ $(use_with xrandr) \
+ $(use_with netplay) \
+ $(use_with zlib) \
+ $(use_with x86 assembler) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with pulseaudio) \
+ $(use_with portaudio) \
+ $(use_with png)
+ fi
+}
+
+src_compile() {
+ games_src_compile
+ if use gtk; then
+ emake -C ../gtk || die
+ fi
+}
+
+src_install() {
+ dogamesbin ${PN} || die
+
+ dohtml {.,..}/docs/*.html
+ dodoc ../docs/{snes9x.conf.default,{changes,control-inputs,controls,snapshots}.txt}
+
+ if use gtk; then
+ cd ../gtk
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/README
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}