summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-08 04:26:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-08 04:26:50 +0000
commit8e41ddbb0939eee3ddee7fecb3e5e751c1c22763 (patch)
tree6913fadd0cca6b88193d169d3ec2ffd6ce70d88c /games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
parent~ppc lovin (diff)
downloadgentoo-2-8e41ddbb0939eee3ddee7fecb3e5e751c1c22763.tar.gz
gentoo-2-8e41ddbb0939eee3ddee7fecb3e5e751c1c22763.tar.bz2
gentoo-2-8e41ddbb0939eee3ddee7fecb3e5e751c1c22763.zip
gtk support #52242
Diffstat (limited to 'games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild')
-rw-r--r--games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..18f9dd26119b
--- /dev/null
+++ b/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/visualboyadvance/visualboyadvance-1.7.2-r1.ebuild,v 1.1 2004/09/08 04:26:50 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="gameboy, gameboy color, and gameboy advance emulator"
+HOMEPAGE="http://vba.ngemu.com/"
+SRC_URI="mirror://sourceforge/vba/VisualBoyAdvance-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="mmx gtk"
+
+RDEPEND="virtual/x11
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/libsdl
+ gtk? (
+ >=x11-libs/gtk+-2.4
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libglademm-2.4
+ )"
+DEPEND="${RDEPEND}
+ mmx? ( dev-lang/nasm )"
+
+S="${WORKDIR}/VisualBoyAdvance-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-homedir.patch"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --enable-c-core \
+ $(use_with mmx) \
+ $(use_enable gtk gtk 2.4) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README README-win.txt
+ prepgamesdirs
+}