summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-29 16:24:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-29 16:24:21 +0000
commit0405d880ab0bd12f03212697fa7d062cf7e8c092 (patch)
tree09cc3e755f424bb8794eb95d7018fa3892c687f6 /games-emulation
parentAdjusting kwin dep to >=4.1.0 instead of slot, as kde-testing overlay is chan... (diff)
downloadgentoo-2-0405d880ab0bd12f03212697fa7d062cf7e8c092.tar.gz
gentoo-2-0405d880ab0bd12f03212697fa7d062cf7e8c092.tar.bz2
gentoo-2-0405d880ab0bd12f03212697fa7d062cf7e8c092.zip
additional gcc43 patching from Tomáš Chvátal via bug #238829
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog6
-rw-r--r--games-emulation/stella/files/stella-2.6.1-gcc43.patch43
2 files changed, 44 insertions, 5 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index ec3615e7ed48..ba5788ed354a 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.31 2008/07/24 17:53:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.32 2008/09/29 16:24:20 mr_bones_ Exp $
+
+ 29 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ files/stella-2.6.1-gcc43.patch:
+ additional gcc43 patching from Tomáš Chvátal via bug #238829
24 Jul 2008; Raúl Porcel <armin76@gentoo.org> stella-2.6.1.ebuild:
x86 stable wrt #232223
diff --git a/games-emulation/stella/files/stella-2.6.1-gcc43.patch b/games-emulation/stella/files/stella-2.6.1-gcc43.patch
index 175c8112d9ac..77a831414196 100644
--- a/games-emulation/stella/files/stella-2.6.1-gcc43.patch
+++ b/games-emulation/stella/files/stella-2.6.1-gcc43.patch
@@ -1,5 +1,6 @@
---- src/emucore/CartAR.cxx
-+++ src/emucore/CartAR.cxx
+diff -urN stella-2.6.1.old/src/emucore/CartAR.cxx stella-2.6.1/src/emucore/CartAR.cxx
+--- stella-2.6.1.old/src/emucore/CartAR.cxx 2008-03-29 00:29:13.000000000 +0100
++++ stella-2.6.1/src/emucore/CartAR.cxx 2008-09-28 11:56:27.000000000 +0200
@@ -17,6 +17,7 @@
//============================================================================
@@ -8,8 +9,9 @@
#include "M6502Hi.hxx"
#include "Random.hxx"
---- src/emucore/Cart.cxx
-+++ src/emucore/Cart.cxx
+diff -urN stella-2.6.1.old/src/emucore/Cart.cxx stella-2.6.1/src/emucore/Cart.cxx
+--- stella-2.6.1.old/src/emucore/Cart.cxx 2008-05-17 01:56:21.000000000 +0200
++++ stella-2.6.1/src/emucore/Cart.cxx 2008-09-28 11:56:42.000000000 +0200
@@ -18,6 +18,7 @@
#include <cassert>
@@ -18,3 +20,36 @@
#include "bspf.hxx"
#include "Cart.hxx"
+diff -urN stella-2.6.1.old/src/emucore/TrackBall.cxx stella-2.6.1/src/emucore/TrackBall.cxx
+--- stella-2.6.1.old/src/emucore/TrackBall.cxx 2008-05-19 05:15:12.000000000 +0200
++++ stella-2.6.1/src/emucore/TrackBall.cxx 2008-09-28 12:28:10.000000000 +0200
+@@ -16,6 +16,7 @@
+ // $Id: stella-2.6.1-gcc43.patch,v 1.2 2008/09/29 16:24:21 mr_bones_ Exp $
+ //============================================================================
+
++#include <cmath>
+ #include "Event.hxx"
+ #include "System.hxx"
+ #include "TIA.hxx"
+@@ -143,8 +144,8 @@
+ else myTrakBallLeft = 0;
+ if(myHCounter < 0) myTrakBallDown = 0;
+ else myTrakBallDown = 1;
+- myTrakBallCountH = abs(myVCounter >> 1);
+- myTrakBallCountV = abs(myHCounter >> 1);
++ myTrakBallCountH = abs(double(myVCounter >> 1));
++ myTrakBallCountV = abs(double(myHCounter >> 1));
+ myTrakBallLinesH = 200 /*LinesInFrame*/ / (myTrakBallCountH + 1);
+ if(myTrakBallLinesH == 0) myTrakBallLinesH = 1;
+ myTrakBallLinesV = 200 /*LinesInFrame*/ / (myTrakBallCountV + 1);
+diff -urN stella-2.6.1.old/src/unix/SerialPortUNIX.cxx stella-2.6.1/src/unix/SerialPortUNIX.cxx
+--- stella-2.6.1.old/src/unix/SerialPortUNIX.cxx 2008-04-11 19:56:34.000000000 +0200
++++ stella-2.6.1/src/unix/SerialPortUNIX.cxx 2008-09-28 11:58:00.000000000 +0200
+@@ -16,6 +16,7 @@
+ // $Id: stella-2.6.1-gcc43.patch,v 1.2 2008/09/29 16:24:21 mr_bones_ Exp $
+ //============================================================================
+
++#include <cstring>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>